Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Modbus help
#1
Hello

We are trying to use a WAGO Modbus TCP module with our PowerPMAC. We currently have the following setup:

PowerPMAC setup with eth0 (first jack) at 192.168.0.200 on our server (172.16.100.XXX) via a hub. We can telnet or IDE from any computer on our network at 192.168.0.200 and connect to PPMAC fine.

Wago 750-352 Modubus TCP module setup on static IP 172.16.100.254 on the same hub. The Wago can be pinged, connected from any computer on our network.

When telneted into the PowerPMAC as root a command of "ping 172.16.100.254" fails. A "ping 172.16.100.65" command is successful (this IP is another computer on our network).

I also noticed that a command of "ifconfig" doesnt list the eth1 port at all, just the eth0 and lo.

Thoughts????

Reply
#2
Should the Modbus be put on the second ethernet jack on the PowerPMAC or does it matter if its physically plugged into a network remotely? Im not sure if it makes a difference but should the WAGO unit be setup with an local to the PPMAC IP address with crossover cable (ie 192.168.0.201) or can it be on a real network with an actual IP?
Reply
#3
MClement,

I tried a similar setup to yours and I can ping the ip 172,16.100.254 from my Power PMAC with static IP of 192.168.0.200 on eth0.

Since you also mentioned that you can ping 172.16.100.65, I would assume we have to look for the problem somewhere else.

How about if you change your Power PMAC IP address to the same subnet as your other devices?

Check this post for help on how to change the IP address: http://forums.deltatau.com/showthread.php?tid=572
Sina Sattari
Chief Engineer
Delta Tau Data Systems, Inc.
Reply
#4
Sina

Thanks, I changed the IP address of the WAGO to be on the subnet with the PPMAC and changed the PPMAC IP address to be on our server and the two seem to be playing nice.

I have a new problem now where I cannot seem to compile the demo Modbus example. It gives me errors about gplib.h. I even tried creating a default project solution and compiling and it also complains about gplib.h.

Thanks

(12-09-2011, 11:24 AM)Sina Wrote: MClement,

I tried a similar setup to yours and I can ping the ip 172,16.100.254 from my Power PMAC with static IP of 192.168.0.200 on eth0.

Since you also mentioned that you can ping 172.16.100.65, I would assume we have to look for the problem somewhere else.

How about if you change your Power PMAC IP address to the same subnet as your other devices?

Check this post for help on how to change the IP address: http://forums.deltatau.com/showthread.php?tid=572

Reply
#5
Where is this "demo Modbus example"?
Sina Sattari
Chief Engineer
Delta Tau Data Systems, Inc.
Reply
#6
It comes with the standard IDE install. Its in the sample projects folder.
Modbuslib example and PowerPMACModbus example

Neither one compiles for me, but then neither does a blank new project so its probably not the Modbus example.




(12-09-2011, 03:12 PM)Sina Wrote: Where is this "demo Modbus example"?



Attached Files Image(s)
   
Reply
#7
(12-09-2011, 06:39 AM)MClement Wrote: Should the Modbus be put on the second ethernet jack on the PowerPMAC or does it matter if its physically plugged into a network remotely? Im not sure if it makes a difference but should the WAGO unit be setup with an local to the PPMAC IP address with crossover cable (ie 192.168.0.201) or can it be on a real network with an actual IP?

A crossover cable is never necessary with a PowerPMAC. You can place the Modbus WAGO unit on the same network as the Power PMAC and IDE. Or if you wish you can make separate network for Modbus and configure ETH1 of the PowerPMAC see http://forums.deltatau.com/showthread.ph...light=eth1 and give it its own network. For example the IDE and your GUI would communicate through 192.168.0.x and your modbus through 192.168.1.x. Using the second ethernet port would result in less network collisions.
Reply
#8
I followed the instructions on the link hbausley sent me and ended up bricking my PPMAC for a short while. I found in another thread to mount the flash as windows drive with a USB and that worked. Now both interfaces eth0 and eth1 come up but I still cannot get the eth1 to connect to the WAGO modbus module.

Here is my configuration.
eth0 set to ip 172.16.150.200
eth1 set to ip 172.16.150.251
Wago set to ip 172.16.150.250

All are set to static IP's. the gateway on all is set to 172.16.150.1 and the masks are 255.255.255.0

I can login to both eth0 and eth1 from anywhere on the network but once into PPMAC a ping to the WAGO fails unreachable. Also if I unplug eth1 and only have eth0 plugged into the network from anywhere on the network I can ping eth1 @ 172.16.150.251 successfully even though its not plugged in physically??

Thoughts?
Reply
#9
(12-13-2011, 08:29 AM)MClement Wrote: I followed the instructions on the link hbausley sent me and ended up bricking my PPMAC for a short while. I found in another thread to mount the flash as windows drive with a USB and that worked. Now both interfaces eth0 and eth1 come up but I still cannot get the eth1 to connect to the WAGO modbus module.

Here is my configuration.
eth0 set to ip 172.16.150.200
eth1 set to ip 172.16.150.251
Wago set to ip 172.16.150.250

All are set to static IP's. the gateway on all is set to 172.16.150.1 and the masks are 255.255.255.0

I can login to both eth0 and eth1 from anywhere on the network but once into PPMAC a ping to the WAGO fails unreachable. Also if I unplug eth1 and only have eth0 plugged into the network from anywhere on the network I can ping eth1 @ 172.16.150.251 successfully even though its not plugged in physically??

Thoughts?

Try placing them on totally different networks. Set eth1 on its own private network ie. 192.168.0.x and leaving eth0 on 172.16.150.x
Reply
#10
I put them on the same network and updated the route table and it works now, with the exception that the route table doesnt seem to be saved after reboot. How do I permanently save the route table?

Thanks everyone for your help.
Reply
#11
(12-14-2011, 01:32 PM)MClement Wrote: I put them on the same network and updated the route table and it works now, with the exception that the route table doesnt seem to be saved after reboot. How do I permanently save the route table?

Thanks everyone for your help.

See this thread it explains that the filesystem is read only.

http://forums.deltatau.com/showthread.ph...e=threaded

If you look in /.readonly/etc-tmpfs-mirror you will see what files were changed when you updated the route table. Can you tell us what you did to update the route table.


So you will do a

mount -o remount,rw /
cp /.readonly/etc-tmpfs-mirror/files cp /.readonly/etc/files
mount -o remount,ro /
Reply
#12
Dear Sir,

I am using wago modbus io 16 digital outputs with geobrick.
modbus modules as below.....
Wago coupler+16 do module+end module.

i did all necessary setting but i don't know modbus ref# for wago do module.
if you have some thing info please share me.

if i have to write coils of wago module,then i have to write any program or configuration to geobrick or is their any setting related to this
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)