Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to make the home search move?
#1
Hi, everyone~

I need to connect the limit and home signal to my Turbo PMAC2 Clipper now.
I read in the HRM that :
   

I use a 34 pin passive Flat Cable commutator for the JMACH2 prot.

So if I use the positive limit for axis 1,

I just connnect pin 1 to a +5V power and pin 7 to a switch linked to the ground of the +5V power?

But I can not see the text "soft or hardware limit" in the flag monitor change its color when I turned on and off the switch.

What should I do?

And what shall I do with pin 2(GND)? No connection?

Thank you for your attention~
#2
The diagram you are looking at from the manual does not explicitly show this, but you should also connect pins 3&4 of the header to the 0v side of the power supply. (If you are using a seperate supply, this is definately true. If you are powering the flags off the same supply as the Clipper then you may not need this connection. I would highly recommend a dedicated supply for the controller and seperate supply for any "field connected" hardware such as I/O)

I would also connect pin 2 to the +V of the supply; but it is only required if using the flags for channels 3 or 4. If not using flags for channel 3 or 4 you can leave it unconnected, but Do Not connect pin2 to 0v or ground.

Also be sure Ixx24 & Ixx25 are set correctly. In particular Ixx24 bit7 should be zero so that the OT inputs are recognized.
#3
(09-22-2011, 06:39 AM)mbalentine Wrote: The diagram you are looking at from the manual does not explicitly show this, but you should also connect pins 3&4 of the header to the 0v side of the power supply. (If you are using a seperate supply, this is definately true. If you are powering the flags off the same supply as the Clipper then you may not need this connection. I would highly recommend a dedicated supply for the controller and seperate supply for any "field connected" hardware such as I/O)

I would also connect pin 2 to the +V of the supply; but it is only required if using the flags for channels 3 or 4. If not using flags for channel 3 or 4 you can leave it unconnected, but Do Not connect pin2 to 0v or ground.

Also be sure Ixx24 & Ixx25 are set correctly. In particular Ixx24 bit7 should be zero so that the OT inputs are recognized.

Sir:

Thank you for your attention.

I connected as the manual shows.
I set the M121:->X:$078000,17
And when I turned the switch, I saw that M121 chaged, but the flag monitor the state for PLIM hardward did not change
and my setting for the variable is almost the same as the example user manual gives:

;*********** Motion Program Set-up Variables (to be saved) *************
CLOSE
I123=-10 ; Home speed 10 cts/msec negative
I124=$920001 ; PMAC-style flags, normal mode
I125=$78000 ; Use Servo IC 0 Channel 1 flags for Motor 1
I126=32000 ; Home offset of +2000 counts
; (enough to take you out of the limit)
I7012=3 ; Capture on rising flag and rising index
I7013=2 ; Use +LIM1 as flag (negative end switch)

and I use the on-line command to make the axis 1 home,

but the axis showed that it complete home search while I did not turned the passive switch.....
here is the position-time curve I got during the "homing" process:
   
would you please give me some advice?

Thank you very much~
#4
Kira,
I'm sorry - in my earlier post I referred to Ixx24 bit7 & I should have said Ixx24 bit17

I think you should review the setting of I124 = $920001
$9 = 1001 bit23=1 amp fault polarity set as needed for your amp
_________bit20=1 amp fault function is turned off (are you sure you want to do this?)
$2 = 0010 bit17=1 ignore OT limits This is why you do not see the OT status change in PWin when you operate the switch
$0 = 0000 bit15=0 disable soft overtravel function
$0
$0
$1

Bit 15&17 set as they are disables all overtravel protection (soft & hard) which is often ok for a rotary axis. Although you are reading the switch operation with M121, it is not being used as an OverTravel by PMAC. Since the OT function is disabled, you could use these inputs as general purpose inputs.
Bit 20 disables the amplifier fault which is generally not a good idea. If you enable this function, you will need to verify bit 23 for correct polarity. If your amplifier does not have a fault output, then leave disabled.

I would consider I124 = $108001 The most significant hex digit will change to either $8 or $0 if you use the amplifier fault function.

With the soft overtravels enabled by bit15=1, you will need to set I113 & I114 to appropriate values. Generally these should be set to a value just before the hard OT switches are reached.
You can set these to zero to disable soft OT temporarily while setting up.

Since the LIM inputs are disabled I think the Home function is reading the input as always true (no overtravel fault) & homing to the marker. Your graph indicates this.
Review the I124 configuration and see if this helps.
#5
(09-22-2011, 03:37 PM)mbalentine Wrote: Kira,
I'm sorry - in my earlier post I referred to Ixx24 bit7 & I should have said Ixx24 bit17

I think you should review the setting of I124 = $920001
$9 = 1001 bit23=1 amp fault polarity set as needed for your amp
_________bit20=1 amp fault function is turned off (are you sure you want to do this?)
$2 = 0010 bit17=1 ignore OT limits This is why you do not see the OT status change in PWin when you operate the switch
$0 = 0000 bit15=0 disable soft overtravel function
$0
$0
$1

Bit 15&17 set as they are disables all overtravel protection (soft & hard) which is often ok for a rotary axis. Although you are reading the switch operation with M121, it is not being used as an OverTravel by PMAC. Since the OT function is disabled, you could use these inputs as general purpose inputs.
Bit 20 disables the amplifier fault which is generally not a good idea. If you enable this function, you will need to verify bit 23 for correct polarity. If your amplifier does not have a fault output, then leave disabled.

I would consider I124 = $108001 The most significant hex digit will change to either $8 or $0 if you use the amplifier fault function.

With the soft overtravels enabled by bit15=1, you will need to set I113 & I114 to appropriate values. Generally these should be set to a value just before the hard OT switches are reached.
You can set these to zero to disable soft OT temporarily while setting up.

Since the LIM inputs are disabled I think the Home function is reading the input as always true (no overtravel fault) & homing to the marker. Your graph indicates this.
Review the I124 configuration and see if this helps.

thank you, mbalentine

but the user manual said that I should disable the OT limit so as to use it as a normal trigger for a trigger move——home search, for example.
Here are the codes I found, and the only difference is that I set I124 $920001 instead of $20000.
P.S.: You said that :the Home function is reading the input as always true (no overtravel fault) & homing to the marker. Your graph indicates this.
would you spare me a moment and explain more about that?

;*********** Motion Program Set-up Variables (to be saved) *************
CLOSE
I123=-10 ; Home speed 10 cts/msec negative
I124=$000000 ; PMAC-style flags, normal mode
I125=$78000 ; Use Servo IC 0 Channel 1 flags for Motor 1
I126=32000 ; Home offset of +2000 counts
; (enough to take you out of the limit)
I7102=3 ; Capture on rising flag and rising index
I7103=2 ; Use +LIM1 as flag (negative end switch)
;*********** Motion program to execute routine *********************
OPEN PROG 101 CLEAR
I124=$20000 ; Disable +/-LIM as limits
HOME1 ; Home #1 into limit and offset out of it
I124=$0 ; Re-enable +/-LIM as limits
CLOSE ; End of program
#6
Kira,
OK, I do have one machine that I use this method so here is a code snippet. I leave the soft OT active and disable Ixx14 by setting to zero.
I do disable the Hard OT for homing. My earlier comments about bit17 were confusing.
Note that I am using the amplifier fault bit.
***********************
I224=$228001 ;Disable limits
I214=0
I424=$228001
I414=0
;
HOME 2,4
;
I224=$208001 ;Enable limits
I214=-42333
I424=$208001
I414=-42333
************************
I would suggest you try using I124=$128001 for home and then set to $108001 after complete.
You could also use I124=$120001 for home if you want to disable the soft OT. You do not need to zero Ixx13 or Ixx14 in this case.

If you are able to use an amp fault signal then the most significant digit will be either $0 or $8 depending on the fault polarity

I think your:
I7102=3
I7103=2
should be :
I7012=3
I7013=2

I7102 & I7103 are clock control registers for the second Gate IC that you likely do not have in your system;
I7012 & I7013 are the homing configuration registers for the first axis.

Hope this helps

Regarding the graph:
I think your I7012 & I7013 may still be at default values which would be "Home to Marker"
The graph shows moving (-10cnt/ms) in the negative direction, at the marker an abrupt change to -2000 (you need to move I126/16= +2000 from here to get to zero), and settling at zero/Home.
Exactly what you have configured.
You're very close to having this complete.


Forum Jump:


Users browsing this thread: 1 Guest(s)