Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Feb 2011 IDE slow??
#1
Hello,

Has anyone else experienced latency problems with the Feb 2011 release of the IDE? It is very often taking me several seconds before a typed character is displayed in an editor window. It appears to be intellisense related in the background C programs editor window.

My computer is a Athlon 64 2.2GHz running on XP with plenty of unused physical memory. I know the computer is dated, but we usually get "hand me downs" for the manufacturing floor.

Is there a way to turn off intellisense in the IDE, this is not tolerable. I'm considering running my emacs editor, which kind of defeats the purpose of using the DT IDE! :o)

Thanks,
KEJR
Reply
#2
Just for reference, I went back to my office PC which is a Pentium 4 D CPU at 2.8GHz, also with XP SP3 and plenty of memory. The editor lag is not hardly noticeable. The other difference is that my office PC is hard wired ethernet, where as the PC on the floor is currently wireless. My project is located on a network drive in both cases. I'll try moving the project to the local drive on the slow PC as a test.

KEJR






Reply
#3
When I have seen that symptom it has been related to MySql. Is the MySql installation on the machine pc good? If you get hard wired ethernet and still have the same issue I would look at the MySql. I am running the 2/7 release without running into that problem (Win7 64 bit).
Reply
#4
There may be some issues related to network access - I've found there are times when the IDE hangs completely but can be kicked into life by starting a browser (which then reauthenticates with the works proxy server ..).

However, network sniffing doesn't show anything continuous on ethernet and I haven't caught the reason for the slowdown - just a 'phone home' to microsoft at startup.

If intellisense is what causes that list of inappropriate completions to hang around and slow down your typing, I can understand why you'd want to disable it. Tools->Options->Text Editor->C language->General->Auto List members is the one you want.

-adrian

Reply
#5
(02-23-2011, 04:30 PM)DavisG Wrote: When I have seen that symptom it has been related to MySql.

Hi Davis,

I'll give this a try. I have not intentionally installed MySql, but it may have been included in some program.

KEJR

Reply
#6
Thanks Adrian,

I'll take a look at what you said and see if disabling intellisense helps. Maybe this is a good excuse to get a fast laptop for the manufacturing floor.

KEJR
Reply
#7
I have only experienced this problem when running the IDE in "No Device" mode. Do you experience the same problem when actually connected to PMAC, or are you also using "No Device" mode?
Reply
#8
This is typically with MySQL service. To check, look at output box. IDE outputs the error in the output box. You can select from View/Output menu. If there is problem with MySQL it will tell you in this window.
The IDE software disables the intellisense if the MySQL service is not started. (Unless there is bug)
Atul
Reply
#9
I ran into some other things and was not able to get back to this issue until now.

I have disabled "auto list" and "parameter information in the "c language" section of options.

I also connected a hardwire 100mbit connection and still I have an approx 1.5 - 3 second lag after typing in the editor screen. I think this might be slightly better than when using wireless, but I can't say for sure.

There are no error messages in the output screen for both "build" and "deltataulog".

Should the editor be doing anything intensive when I'm just typing code (especially with intellisense turned off)?

As an additional debug note I put the project on the C:\ drive and the delay got noticeably better.. it is now maybe 0.25-0.5 second delay after entering a character. At this speed it is hard to quantify with any sort of precision what the timing is, but it is very noticeable. This implies to me that the editor is going out to the filesystem while I'm typing.

Another note is that the lag does not seem to be apparrent or noticable when I am typing numbers. If I just hammer on "1234" over and over again it appears to be fast. If I do "asdf" it pauses after "a" and then "sdf" appears on the screen after the delay.

KEJR
Reply
#10
(03-02-2011, 08:14 AM)KEJR Wrote: I ran into some other things and was not able to get back to this issue until now.

I have disabled "auto list" and "parameter information in the "c language" section of options.

I also connected a hardwire 100mbit connection and still I have an approx 1.5 - 3 second lag after typing in the editor screen. I think this might be slightly better than when using wireless, but I can't say for sure.

There are no error messages in the output screen for both "build" and "deltataulog".

Should the editor be doing anything intensive when I'm just typing code (especially with intellisense turned off)?

As an additional debug note I put the project on the C:\ drive and the delay got noticeably better.. it is now maybe 0.25-0.5 second delay after entering a character. At this speed it is hard to quantify with any sort of precision what the timing is, but it is very noticeable. This implies to me that the editor is going out to the filesystem while I'm typing.

Another note is that the lag does not seem to be apparrent or noticable when I am typing numbers. If I just hammer on "1234" over and over again it appears to be fast. If I do "asdf" it pauses after "a" and then "sdf" appears on the screen after the delay.

KEJR

Did you check the MySQL service? Do you see same amout of delay typing in the terminal window? Termianl, watch as well as editor all use intellisense.
Atul
Reply
#11
(03-02-2011, 08:32 AM)agovande Wrote: Did you check the MySQL service? Do you see same amout of delay typing in the terminal window? Termianl, watch as well as editor all use intellisense.
Atul

I did check the output window as you suggested and saw no errors of any type. Is there anything else to check? I'm not familiar with MySQL.

The same delay is not present in the terminal window.

KEJR
Reply
#12
(03-02-2011, 08:37 AM)KEJR Wrote:
(03-02-2011, 08:32 AM)agovande Wrote: Did you check the MySQL service? Do you see same amout of delay typing in the terminal window? Termianl, watch as well as editor all use intellisense.
Atul

I did check the output window as you suggested and saw no errors of any type. Is there anything else to check? I'm not familiar with MySQL.

The same delay is not present in the terminal window.

KEJR
This is getting interesting if you see no delay in the terminal then intellisense engine is working fine. This is the same engine used in editor. Are you opening the project over the network ? It is possible the slowness due to network delay
Atul
Reply
#13
ok - working with a project having ~10000 named variables in .h and .pmh files (almost entirely pointers to shared memory) I am seeing the same slowdown. Atul has also seen this, can repeat it, and is looking into what, if anything, can be done about it.
Reply
#14
(05-04-2011, 02:21 PM)DavisG Wrote: ok - working with a project having ~10000 named variables in .h and .pmh files (almost entirely pointers to shared memory) I am seeing the same slowdown. Atul has also seen this, can repeat it, and is looking into what, if anything, can be done about it.

I think your problem is different then this one. You do not have speed problem in editor whereas he does. You see problem in terminal window and he does not.
Atul
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)