Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Plot Data Gather Greyed out
#1
I have an issue on my desktop where the Delta Tau --> Tools --> Plot feature doesn't work?

To this point I had only tuned on my Laptop which works fine but now I am an a point where I wanted to do some runtime adjustments from the shop while monitoring via ip cameras.

I can't seem to figure out what is wrong. I uninstalled and reinstalled and tried all kinds of different things but the Data Gather option just stays greyed out. If I switch to Legacy mode it appears to let me gather but the upload portion locks up and never completes.

Any ideas would be appreciated.

I am going to try and clear my registry settings and user profile settings next but just wanted to reach out and see if this is a known issue with a solution.
Reply
#2
What IDE version are you using, what firmware version is this particular PMAC using, what PMAC type is it (CPU + form factor), and does the plot feature work for any other computers?


It may be that your firewall is blocking "DeltaTauGatherProgram"--be sure to give that process the full permissions in your windows firewall. It sounds like the problem is specifically when trying to pull all the data off of the PMAC ("normal" mode streams the data continuously, "legacy" leaves it in the PMAC and only transfers it when you click Upload), so this is the most likely culprit. If this doesn't solve it, then please provide the info above in case any of it is relevant, since it might be a firmware/software mismatch or something.
Reply
#3
I am using IDE 4.4.1.7 with a Power UMAC, PowerPC,460EX Firmware: 2.5.1.2

Same IDE revision and configuration on my laptop and plot works fine.

I have disabled my firewall completely and there was no change.

I attached a screenshot.


Attached Files Image(s)
   
Reply
#4
Hi Mr. Beasley,

Could you please provide the version of windows that you are using and a capture of your Windows Firewall settings for applications specifically? (Located at: Control Panel - All Control Panel Items - Windows Defender Firewall - Allowed Apps)

I have attached a screen shot of my Windows Firewall settings as it pertains to allowing the DeltaTauGatherProgram application through with Domain, Private and Public rights. These need to be set in order for the Plot to function properly.

Please make these changes with your Windows Firewall activated and update us on your current status so we can better assist your issue.

Thank You

-R.Roy


Attached Files Image(s)
   
Reply
#5
I don't think the issue is firewall related, but I could be wrong. Is there a way i can issue some manual commands to the datagather console app to get more debug information?

Attached are screenshots of the requested information.


Attached Files Image(s)
       
Reply
#6
It just felt like it had to be firewall, because it really does seem like the "transfer data from PMAC to computer" step is specifically what's being blocked.

Are you able to do a motor tuning move (a Step move, for instance) in the Tune tool, and do you get a plot when you do?

It's sounding like this may be something fairly specific to this computer/installation. Would you mind sending an email to odt-support@omron.com (and include a link to the forum post in the body)? I think at this point it may be easier to troubleshoot this over email.
Reply
#7
Definitely a network/firewall issue just not on my computer.

I could not Tune Either but I have a shop PowerPMAC that I have tuned many servos on.

When I disconnect from the PMAC out on in the Plant and connect to my local unit I have Plot and Tune options.

There must be something getting blocked by my hardware firewall between my shop and the factory floor that the NAT translation is not handling properly maybe some kind of UDP connection.

I will shoot you an email but first I'm going to look at the netstat while connected to my local unit and try and port forward the connections from the factory.

Thanks
John.
Reply
#8
Multiple instance of the gather program appeared in my firewall with different capitalisation (see screenshot).

I had to allow them all through to get the plot program working correctly.

Try manually adding another rule and see if you also find another version with capital letters in the name.


Attached Files Image(s)
   
Reply
#9
Got it figured out. Took a little bit of work but it was my hardware firewall.

It anyone else has this issue you just need to port forward TCP / 18999 through your firewall to the Machine running the IDE. When you open the Tune or Plot interface the IDE starts a listener on the Local Computer and then runs netcat on the remote PMAC to stream the data across.

The options to gather stay greyed until the connection from the PMAC to the Local IDE is completed.

Hope everyone has a great Thanksgiving.
John.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)