Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Communication problem PMAC2A-PC/104
#1
I'm using a setup with:
CPU (80 Mhz)
ACC 1P
ACC 2P (with USB and Ethernet)

I'm having problems reestablishing an ethernet connection to the PMAC.
After cold starting the PMAC I can't ping it at its usual 192.6.94.5.
When I connect my Win10 via USB the PMAC is identified as "Delta Tau UMAC USB 2.0 Device No EEPROM" in the Device Manager.
I can use the EthUSBConfigure.exe (from PMAC Executive Pro2 Suite 4.4.0.0) to set the IP, Protocol (TCP 1025) and the "H/W Type" (PC104) with a click on "Store IP". After replugging the USB cable the Motion controller is now identified (correctly): Delta Tau PC104 USB Device.
At this point I can finally use PeWin32Pro again or even ping the PMAC, however after a cold start of the PMAC the set parameters will be lost and the Device Manager shows "Motion Controllers: Delta Tau UMAC USB 2.0 Device No EEPROM" again.

Can you help me with the setup please?
Reply
#2
Check your 5V power supply. I have seen something similar when the rise time of the 5V was too slow. We were using a DC-DC converter and for us the solution was to use a relay to turn the 5V on after the DC-DC was switched on.
Reply
#3
Ok, I checked the power supply and raised its voltage even a bit but no change yet. I'll try to measure the risetime somehow. Unfortunately the system is in use most of the time, so I can't just do changes/measurements there at any time.

Another thing occurred to me when I tried to check for voltage changes.
When I have just cold started, Device Manager shows "Delta Tau UMAC USB 2.0 Device No EEPROM" and PeWin says "no connection possible", I usually use EthUSBConfigure.exe by pressing "Store IP" and "Done". Then PMAC dissapears from Device Manager and I have to replug USB cable to find "Delta Tau PC104 USB Device". This time I just pressed the red cross for "Close" by Windows without pressing "Store IP" or "Done" and PMAC dissapeared from Device Manager again to reappear as "Delta Tau PC104 USB Device" after replugging of USB cable. How is this software working when even closing leads to a change?!?
A simple replugging of USB cable without using the software isn't changing anything of course.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)