Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Handwheel-Position Following mode
#1
Hello,

I'm currently using the Position-Following mode to implement a Jog/Increment Handwheel. I'm enabling following in normal mode (Motor[x].MasterCtrl = 1). I'm running into one issues with its behavior.
The handwheel control axis normal at 0.1mm and 1mm per revolution, but the mechanism will make abnormal sound at 10mm per revolution, and it is normal at other modes of control.The handwheel has 400 pulses per turn,The controller CK3E,Is there any parameter that can improve this situation?
Reply
#2
This is probably a result of “noise” in the master position being “amplified” by Motor[x].MasterPosSf. You can use the “Motor[x].SlewMasterPosSf” to “filter out” noise. For details see the description of this parameter in the “Power PMAC Software Reference Manual” starting on page 521. Also see the section “Processing the Master Position Signal” in the “Power PMAC User’s Manual” for other suggestions, starting on page 769 (770 electronic).
Reply
#3
(05-13-2020, 01:58 PM)steve.milici Wrote: This is probably a result of “noise” in the master position being “amplified” by Motor[x].MasterPosSf. You can use the “Motor[x].SlewMasterPosSf” to “filter out” noise. For details see the description of this parameter in the “Power PMAC Software Reference Manual” starting on page 521. Also see the section “Processing the Master Position Signal” in the “Power PMAC User’s Manual” for other suggestions, starting on page 769 (770 electronic).

Thanks for your reply. You're right.
I used the "Motor[x].MasterMaxSpeed" and "Motor[x].MasterMaxAccel" to basically solve the problem.
Reply
#4
The feedforward servo gains on the follower motor can end up trying to predict the future behavior of the master encoder, leading to noise. You might try these settings for the follower motor:
Code:
Motor[x].Servo.Kaff=0
Motor[x].Servo.Kvff=Motor[x].Servo.Kvfb
Motor[x].Servo.Kviff=Motor[x].Servo.Kvifb
Reply
#5
(05-14-2020, 02:27 PM)Eric Hotchkiss Wrote: The feedforward servo gains on the follower motor can end up trying to predict the future behavior of the master encoder, leading to noise. You might try these settings for the follower motor:
Code:
Motor[x].Servo.Kaff=0
Motor[x].Servo.Kvff=Motor[x].Servo.Kvfb
Motor[x].Servo.Kviff=Motor[x].Servo.Kvifb

Thanks Eric,I'll try your method.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)