Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Open loop does not respect physical limit switches
#1
Hi!

I was doing some tests with out command:

Quote:#1out0.1
#1out-0.1

to move my stepper motor in open-loop. Software manual (page 434) says:

Quote:Bit 1 (value 2) controls the action when this motor is in open-loop enabled mode (as from an online outn or buffered coutn command) and the motor hits an overtravel limit (hardware or
software), or the coordinate system operation is aborted (abort or adisable command,
aborting error or run-time error in the coordinate system). [..]

But when my stage reach the limit switch, it does not stop. I tried setting Motor[x].FaultMode to 0 or 2 and both of them does not stop in closed loop or kill respectively.

Am I forgetting something? There is some other configuration that I should do to operate this motor in open-loop on a safe manner?

Thanks!
Reply
#2
Can you confirm whether or not PMAC is reading it as a limit switch, or reading it as the correct limit switch?

In the "Motor Status" tab of a "Status" window, select the correct motor number and manually toggle the limit switches--you should see bits "PlusLimit" and "MinusLimit" go true and false. If you do not, then verify Motor[x].pLimits and Motor[x].LimitBits, along with verifying that your switches are wired into the correct inputs.
Reply
#3
Thanks for replying!

(03-04-2020, 08:15 AM)AAnikstein Wrote: Can you confirm whether or not PMAC is reading it as a limit switch, or reading it as the correct limit switch?

The controller is reading limit switches correctly.

Quote:In the "Motor Status" tab of a "Status" window, select the correct motor number and manually toggle the limit switches--you should see bits "PlusLimit" and "MinusLimit" go true and false.

I validated the connections and the switches, pressing manually the positive and negative limit switches cause MinusLimit and Plus limit flag rise up on motor status wiondow .

Quote:If you do not, then verify Motor[x].pLimits and Motor[x].LimitBits, along with verifying that your switches are wired into the correct inputs.

My Motor[4].pLimits=PowerBrick[0].Chan[3].Status.a and Motor[4].LimitBits=9 are correctly set.
Reply
#4
Hi AAnikstein!

Maybe the problem is a bug on firmware. My coworker found it on this thread http://forums.deltatau.com/showthread.ph...ight=Limit

I am using firmware 2.5.0.4
Reply
#5
George,

You are correct, this is a firmware bug. While there has not yet been a firmware release since that was discovered, it will be releasing soon, and we may be able to give it to you early in the meantime.

Please email "ODT-Support@omron.com" and reference this thread. In the email, please also include your system's response to the "cpu" command when issued in the IDE. Different CPUs require different firmware, and this will help us make sure we give you the correct file.
Reply
#6
AAnikstein,

I sent the e-mail as you requested.

Also the answer for "cpu" command is:

Quote:PowerPC,APM86xxx
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)