Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
motor setup difference between IDE 4.32.19 AND 4.1.0.24
#1
I set up the G5 servo and motor in IDE 4.1.0.24. I got a new laptop and installed it with IDE 4.32.19. Then I cannot download the same project. I even cannot set up the motors in the same way as the old IDE.
Reply
#2
Motor setup should be fairly similar between IDE 4 versions., although the location to enter some settings has been moving around within the motor setup tree. What errors do you get attempting to download the same project? Are you trying to set up motors manually or through our system setup GUI?
Reply
#3
Now I just try to manually set up the motor. At the last step, I try to jog the motor, but it won't move. "motor not moving". I have no problem setup the motor following the instruction from Omron called "Startup Guide G5-series Servo Drivers(IDEV4)" on IDE 4.1. Now I am following the user manual of PowerPMAC IDE O016-E-05, I am not able to jog the motor.

What is your system setup GUI?

Thanks,
Reply
#4
the attached is the snapshot of what I get.


Attached Files Image(s)
   
Reply
#5
What firmware version do you have installed? Somewhere in IDE 4 development, we started required firmware 2.5+ for the tuning done at the end of system setup. The motor may be un-tuned still.
Reply
#6
Is this a ethercat G5 in position mode? It may be that ethercat is not enabled. What are the values of ECAT[0].Enable and ECAT[0].MasterState?
Reply
#7
(02-18-2020, 11:22 AM)Eric Hotchkiss Wrote: What firmware version do you have installed? Somewhere in IDE 4 development, we started required firmware 2.5+ for the tuning done at the end of system setup. The motor may be un-tuned still.

it's 2.5.1.7.

The motor is not tuned. In Tune window, no motor there, motor is offline. Here is the description "Cannot determine Local IP.Cannot determine Local IP.Cannot Determine Host IP".
Reply
#8
(02-18-2020, 04:25 PM)Eric Hotchkiss Wrote: Is this a ethercat G5 in position mode? It may be that ethercat is not enabled. What are the values of ECAT[0].Enable and ECAT[0].MasterState?

This is an Ethercat G5 in position mode. The Ethercat is enabled.
ECAT[0].Enable=1 and ECAT[0].MasterState=8

Now the motors are moving. I might miss one step before.

But the motors are still not tuned. In the tune window there is no motor.
Reply
#9
Quote:Now the motors are moving. I might miss one step before.
I'm happy to hear that.

Quote:The motor is not tuned.
Since you are in position mode, the motors are tuned in the Amplifier (the G5), not the controller (the PMAC). As long as you can jog the motors.

Quote:In Tune window, no motor there, motor is offline. Here is the description "Cannot determine Local IP.Cannot determine Local IP.Cannot Determine Host IP".
Can you give a screenshot?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)