Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The EtherCAT slave is going into SafeOp state
#1
Hello sir,

We have a ck3e with the EtherCAT option, that we have connected to a following EtherCAT devices.The topology is daisy chain and network is as follows:

Master - ck3e
Slave 0 - C1250-DS-XC-1S (Drive)(has reference distributed clock box checked in settings)
Slave 1 - C1250-DS-XC-1S (Drive) (has reference distributed clock box unchecked in settings)
Slave 2 -R88D-1SN04H-ECT (Drive) (has reference distributed clock box unchecked in settings)
Slave 3 -R88D-1SN04H-ECT (Drive) (has reference distributed clock box unchecked in settings)
Slave 4 -NX-ECC203(EtherCAT coupler) (has reference distributed clock box unchecked in settings) to which following modules are connected,
->NX-EC0122
->NX-ID5442
->NX-OD5256
The servo frequency is 1Khz.
I checked the distributed clock which is working fine (by checking the parameter Ecat[0].DcclockDiff)
while application is running the ethercat coupler(slave 4) is going into SafeOp state and output module is showing error.
The other all devices are not showing any error and state is operational.
I just wanted to ask what would be a reason because of which ethercat coupler is going into SafeOp?? how should I diagnose the same.
Also after giving "ecat reset" command in the terminal the problem is resolving.
Let me know if you need any other details,any help would be great, thank you for your time :)

Regards,
Durgesh
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)