Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IDE 4.3.2.19 - Can't Kill Motors
#1
This is kind of a deal breaker.

Object reference not set to instance of an object.

Comes up on CTRL-ALT-K and when selecting it from the Menu List.

Ran Full install on two workstations same result on both. I did a uninstall of the last version and an install of the new version.

Rolled back to (4.3.0.107) worked fine. Tried just the update patch and same result?

Removed and reinstalled 4.3.0.107 and everything is working fine?

For comparison I did a clean install on Windows 7 of 4.3.2.19 and it works fine no error?

Thanks
John.
Reply
#2
John,

Were both computers addressing the same system? If not, is there anything that might explain it between the systems (number of motors active/enabled, maybe changes to Sys.MaxMotors or something since last boot)?

I'm on Windows 10 and cannot replicate it yet with the hotkey or the menu button, but I'm going to have more people test this specifically.

Can you send us a picture of the error message, either posting it on the forums or emailing it to odt-support@omron.com?
Reply
#3
Here is the screen shot. Yes both Computers were accessing the same Power PMAC BrickLV Controller. No changes at all to the Controller or Control Program. All other functions work fine. I didn't notice it until I tried to kill a jog move. Then the error popped up and the motor kept running so I had to run over and e-stop the machine.

Attached is the picture.


Attached Files Image(s)
   
Reply
#4
(11-04-2019, 05:41 PM)jbeasley Wrote: Here is the screen shot. Yes both Computers were accessing the same Power PMAC BrickLV Controller. No changes at all to the Controller or Control Program. All other functions work fine. I didn't notice it until I tried to kill a jog move. Then the error popped up and the motor kept running so I had to run over and e-stop the machine.

Attached is the picture.

Hello,
Can you open a terminal window and then try the command ?
From your picture you have IDE and watch window.
Thx,
Atul
Reply
#5
It does the same thing.

I used the #*DKill from the terminal and it kills the motors. All other features of the IDE are working fine. Here is the same output with the terminal window open. I ran a few commands. I'm online with the controller. I have been updating motion programs with it and running them no problem.

I just get that popup when I hit CTRL-ALT-K.

I will try a complete removal of all IDE items and then reinstall and see what happens. Like i said. I ran a clean install on a laptop I use for PLC programming and it works fine no errors but it never had any version of PPMAC IDE installed.

Thanks
John.


Attached Files Image(s)
   
Reply
#6
It is specific to the user profile.

I removed everything related to the PMAC IDE and then renamed the "C:\Delta Tau" directory to "C:\Delta Tau.OLD" then did a complete install and same problem came up. I then created a new user on the System with Administrative Privileges.

Logged in and Opened the PPMAC IDE and the KILL shortcut works fine.
Reply
#7
I have now narrowed it down to the auto connect feature.

I had set the Select/Device At Startup to False since I only have the one power pmac controller.

If I open my IDE and try the shortcut I get the error. Even though it says communications successful connected in the terminal window.

If I click Communications setup, change nothing and click apply.

It disconnects and reconnects to the same pmac and the Kill command works fine. No error.

Close and reopen. Error again.

I went to Tools-->Options-->PowerPMAC-->Communications Setup

Set SelectDeviceAtStartup back to True.

Closed and reopened, Click Connect when prompted and now everything works fine.

Thanks
John.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)