Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Omron R88D-KN15F not work #1j/
#1
Hello!
I configured the drive in accordance with the OMRON G5 EtherCAT instructions. By command # 1out0, the drive turns on, and 00 appears on the drive indicator. When I turn on the drive in servo mode, the FeFatal motor error. I use a motor with an incremental encoder.
What have I done wrong?

Filled the following values in the IOData column:
# x6060 10
# x607F 83886080 for 20-bit incremental encoders.
# x60E0 3000
# x60E1 3000
Type of drive R88D-KN15F-ECT and motor R88M-k1k030F-S2.
Best regards Andrey.
Reply
#2
Please take a look at the setting for Motor[1].FatalFeLimit. This is a following error limit above which the motor is killed. The default after a $$$*** is 2000, which is very low compared to the 17 or 20 bits of position data from the G5.

In IDE 4 system setup, this may show up in motor commissioning or safety review sections.
Reply
#3
I am using a controller Power PMAC Clipper, IDE 3.1.4.0
Incremental encoder 20 bits.
When I turn on the drive #1j/, disconnected by mistake FeFatal.
Motor [1] .FatalFeLimit. = 3000;
Help me please.
Reply
#4
(10-23-2019, 09:48 AM)andreychip Wrote: I am using a controller Power PMAC Clipper, IDE 3.1.4.0
Incremental encoder 20 bits.
When I turn on the drive #1j/, disconnected by mistake FeFatal.
Motor [1] .FatalFeLimit. = 3000;
Help me please.

Its possible that you're PID tuning might be causing the motor to just when it is being enabled. You can verify this using the scope feature of the IDE and look at the following error for motor 1 when you enable it.

If you want to just get things going and do the tuning later, make sure your setup in in a SAFE STATE for the motor to run away. I'd say just have the motor sitting on its own then set the following error to inf corresponding to there is not following error limit at all. Then try to enable your motor to see if it still trips.

Another thing, make sure that your encoder direction sense is correct. If it isn't then this will definitely cause a run away. You can fix this in software by setting the scale factor to a negative or positive number depending what it is now.

AGAIN MAKE SURE YOUR MOTOR IS IN A SAFE STATE TO POSSIBLY RUN AWAY UPON ENABLING IT.
Reply
#5
Thanks for the answer. I tuned in Cyclic synchronous position mode and the drive worked.
When setting in the Cyclic Synchronous Torque Mode, I reset Motor [1] .FatalFeLimit. =0 the error variable,
the engine vibrated a lot, changing the coefficients nothing helped.
Slave_0_6060_0_Modesofoperation=10;
Slave_0_607F_0_Maxprofilevelocit=exp2(20)*3000/60;
Slave_0_60E0_0_PositiveTorqueLim=3000;
Slave_0_60E1_0_NegativeTorqueLim=3000;
if 60Е0 = 100 and 60Е1 = 100 there is no moment, but does not knock out. The direction scaling factor makes it even worse.
Thanks for the help. If you need a complete setup I will write.
Reply
#6
Audrey,

Is the value of Motor[1].PosSf 1? I am assuming it is and your motor is set up in counts.

Motor[1].FatalFeLimit is the following error at which the motor is killed (power to the motor is cut). It is in the same units as your motor position. Your original fatal following error would be equivalent to 2000*360/2^20=0.7 degrees. That might be a little bit small depending on your mechanics, tuning, etc. By setting this value to 0, you disabled the feature and the motor will not be killed. You might want to try setting this to some number of degrees. For 10 degrees Motor[1].FatalFeLimit = 10/360*2^20

In torque mode you will have to tune the motor in PMAC's tuning tool, while position mode was tuned on the drive's software (sysmac studio). What IDE version do you have so I can show you where this tool is?
Reply
#7
(10-25-2019, 09:30 AM)Eric Hotchkiss Wrote: Audrey,

Is the value of Motor[1].PosSf 1? I am assuming it is and your motor is set up in counts.

Motor[1].FatalFeLimit is the following error at which the motor is killed (power to the motor is cut). It is in the same units as your motor position. Your original fatal following error would be equivalent to 2000*360/2^20=0.7 degrees. That might be a little bit small depending on your mechanics, tuning, etc. By setting this value to 0, you disabled the feature and the motor will not be killed. You might want to try setting this to some number of degrees. For 10 degrees Motor[1].FatalFeLimit = 10/360*2^20

In torque mode you will have to tune the motor in PMAC's tuning tool, while position mode was tuned on the drive's software (sysmac studio). What IDE version do you have so I can show you where this tool is?

I am using a controller Power PMAC Clipper, IDE 3.1.4.0

installed Motor[1].FatalFeLimit=50000 more than. Also tried to change the coefficients Kp Kd Kvf.
Reply
#8
It sounds like you still need to tune the motor. First navigate to "Delta Tau" -> "Tools" -> "Tune".
Next follow the instructions starting on slide 183 of the training slides below:
http://forums.deltatau.com/filedepot/dow...202016.pdf
Reply
#9
(10-28-2019, 09:34 AM)Eric Hotchkiss Wrote: It sounds like you still need to tune the motor. First navigate to "Delta Tau" -> "Tools" -> "Tune".
Next follow the instructions starting on slide 183 of the training slides below:
http://forums.deltatau.com/filedepot/dow...202016.pdf
Thanks for the help.
Torque setting failed no works.
Positional mode works.
Reply
#10
Tuning an EtherCAT drive often results in very different gains than a local drive.
For normal (not EtherCAT) motors, Kp/Kd values often are in the hundreds/thousands/ten thousands.
For EtherCAT Torque Mode, it is not uncommon to see fractional values (<1).
Unfortunately, I cannot recommend gains for that particular drive as I have not tested it.

If you are happy with the performance in position mode, feel free to continue using it like that.
If you need to put it into Torque mode, start off with very small values (Kp = 0.001, all other gains = 0) and then go from there.
As windell emphasized, make sure your motor is in a safe state first as it may be unpredictable.
Reply
#11
(10-29-2019, 10:08 AM)AAnikstein Wrote: Tuning an EtherCAT drive often results in very different gains than a local drive.
For normal (not EtherCAT) motors, Kp/Kd values often are in the hundreds/thousands/ten thousands.
For EtherCAT Torque Mode, it is not uncommon to see fractional values (<1).
Unfortunately, I cannot recommend gains for that particular drive as I have not tested it.

If you are happy with the performance in position mode, feel free to continue using it like that.
If you need to put it into Torque mode, start off with very small values (Kp = 0.001, all other gains = 0) and then go from there.
As windell emphasized, make sure your motor is in a safe state first as it may be unpredictable.

Thank . I tried with Kp = 1, tomorrow I will write what happened.
Reply
#12
Many thanks to all, special thanks to AAnikstein. I managed to configure it in torque mode.
Below are the parameters that turned out:

Motor[5].Servo.Kp=0.026616275
Motor[5].Servo.Kvfb = 0.46887201
Motor[5].Servo.Kvff = 0.46887201
Motor[5].Servo.Ki = 0.015661255
Motor[5].Servo.Kaff = 4.0185695
Motor[5].FatalFeLimit = 20000
Motor[5].WarnFeLimit = 8000
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)