Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DC (Distributed Clock)
#1
Hello sir,

I have a few doubts regarding distributed clock feature in EtherCAT communication. I have performed following steps and observations are as below,

1. I connected the PPMAC 465 CPU directly to one ABB Motiflex E 180 drive and mapped required PDO’s in PPMAC
2. Phase frequency = 4khz
3. Servo frequency = 1khz
4. Mode of operation is set to 10
5. After configuring the one motor as above, It is running in torque loop from controller side but with distributed clock not working correctly (ECAT[i].DCClockDiff is drifting in only one direction)
6. I also performed exactly same steps (using EC Engineer software) with ARM CPU and the distributed clock is working correctly. (ECAT[i].DCClockDiff is fluctuating around a nonzero value)

My questions are,

1. In both of above configurations, the RAMP Response RMS errors are similar, so what function DCClock features serves?
2. If we keep distributed clock feature disabled on PPMAC, Will it impact servo performance in any way? The number of slaves will be 8 in actual application.

Let me know if you need any other details,

Thanks,
Durgesh
Reply
#2
The EtherCAT distributed clock (DC) feature is a requirement when using a servo drive.

The IDE’s “System Setup” would have provided messages in the “output” tabs indicating any issue in setting up the EtherCAT DC. Try the setup again and view the messages.
Reply
#3
(09-20-2019, 01:31 PM)steve.milici Wrote: The EtherCAT distributed clock (DC) feature is a requirement when using a servo drive.

The IDE’s “System Setup” would have provided messages in the “output” tabs indicating any issue in setting up the EtherCAT DC. Try the setup again and view the messages.

Thanks in advanced.
With PPMAC 465CPU I performed steps as mentioned in the manual. and observed the output tab as you mentioned above.There was no error,but when I entered Assign Activate value 300 (same as the value is read from the device’s xml file) and accepted the setting after that the EtherCAT is not enabling.
Reply
#4
This would be a technical support issue.

Please contact your local Omron Technical Support Center for further assistance.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)