Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
plot upload fail
#1
I'm trying to use the plot feature of the PPMAC IDE. The gather button seems to work but the upload button never finishes. I have a very simple setup sampling motor 8 actpos, despos, iqcmd, processing motor 8 cmd position, following error. Plotting following error on left axis, cmd position on right axis. Max gather samples 10, sample period 10. The window says Legacy Mode in the lower left corner.

Any ideas why it is unable to upload the sampled data?

Thanks!


Attached Files Image(s)
   
Reply
#2
What are your IDE and firmware versions? Has plotting in general worked for you on this IDE install and PMAC previously? Have either version changed recently?

Normally as long as the IDE and firmware versions are from near the same time, there is no need for legacy mode at all, so they might be too far apart.
Reply
#3
I think I only tried using plot once before and it didn't work then. I don't want to try changing versions of the IDE or firmware at this time since the system has just been installed in the field and I don't want to risk breaking it.
Reply
#4
I understand, but if you give me version numbers I can at least see if they work for me and if we're lucky get advice from the software team on how to fix your install.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)