Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Actual Position Value fluctuating-Acc84E
#1
Hello,

We are facing a problem with the actual position value with the below configuration. We are interfacing absolute SSI 22 bit encoder with PPMAC 465 CPU using ACC-84E. We have the following configuration

Acc84E[14].SerialEncCtrl=$633102
Acc84E[14].Chan[0].SerialEncCmd=$1c16
Sys.ServoPeriod=0.25
Sys.PhaseOverServoPeriod=1

We can read the value but the actual position value is fluctuating. Do you know the expected settings to make the reading stable?

Regards,
Durgesh
Reply
#2
Can you be more specific? Is the position rolling over?

Please check Motor[1].pEnc (or replace the 1 with your motor number.
Your response should be like Motor[1].pEnc=EncTable[x].a where x is enctable number
Issue "backup Enctable[x]." in the terminal. No quotes, but you'll have to his escape to get rid of the intellisense suggestion.
Copy the Enctable[x] settings into a reply.
Reply
#3
(06-21-2019, 09:59 AM)Eric Hotchkiss Wrote: Can you be more specific? Is the position rolling over?

Please check Motor[1].pEnc (or replace the 1 with your motor number.
Your response should be like Motor[1].pEnc=EncTable[x].a where x is enctable number
Issue "backup Enctable[x]." in the terminal. No quotes, but you'll have to his escape to get rid of the intellisense suggestion.
Copy the Enctable[x] settings into a reply.

Hello Eric,
Thanks for the reply.
I have executed commands suggested by you. I am attaching the image of the output of the command.

Thanks.


Attached Files Image(s)
   
Reply
#4
If you put Acc84E[1].Chan[1].SerialEncDataA (important to leave off the .a) in the watch window, do you also see fluctuations?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)