Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Closeloop testing of PZT actuator with strain gauge sensor
#1
Dear All,
We have a couple of project with PZT actuator recently. We use Turbo PMAC 2 as our controller.We have 6-axis cards, I/O card, CPU & A/D card mounted on UMAC rack.

I need help to make a closedloop for the PZT actuator with integrated strain gauge sensor. The sensor output is 0-10V. We shall use the Amplifier 3 for the PZT input and we need to use the A/D card for the feedback. We already have 2 axes configured on to the axis card.

1)How to make closedloop with strain gauge analogue feedback?
2) How to define/assign an axis name say (A-axis) to the amplifier 3
3) How to add this axis with the existing 2-axes? Eg: G01 X10 Y10 A10 (mm, mm, microns)

Looking forward your valuable support.

Regards,
Raghav
Reply
#2
Whether using the ACC-28E or 36E, their hardware reference manuals have Turbo setup sections that describe how to setup unipolar inputs and assign as servo feedback.

Defining an axis in PEWIN can be done in the Terminal Window or in the Coordinate System setup window (from under the Configure tab). See in the Turbo Software Reference manual under the description for #{constant}->{axis definition}.
If you are working with a CNC software application, the definition should be done within that software, at least for with any Delta Tau NC software.
Reply
#3
(04-25-2019, 08:40 AM)Gregs Wrote: Whether using the ACC-28E or 36E, their hardware reference manuals have Turbo setup sections that describe how to setup unipolar inputs and assign as servo feedback.

Defining an axis in PEWIN can be done in the Terminal Window or in the Coordinate System setup window (from under the Configure tab). See in the Turbo Software Reference manual under the description for #{constant}->{axis definition}.
If you are working with a CNC software application, the definition should be done within that software, at least for with any Delta Tau NC software.

Thank you Gregs for your response.

Will try to go through the manual. Can you help me to fix the open loop test? I need some advice on the same.

Regards,
Raghav
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)