Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ECAT Setup in IDE4
#1
I have a CK3M with 1S servo and am trying to configure an EtherCat connection using IDE4.2.1.19
I am able to scan the network, setup the connection, transfer to the CK3M, and finally activate the EtherCat network without errors. Good.

Next I try to setup the motor, which starts out good, but when I get to the Hardware interface screen I get a bunch of Hardware Mismatch listings for Command signal channel, Amplifier Enable Signal Output Channel, Amplifier Fault Signal Input Channel, and Primary Feedback Channel, where I should instead be able to set the PDO variables that contain my data.

Any idea what to do here?
I haven't found any walkthrough/guides for ECAT config on IDE4. Is anything available?

Many Thanks,
Doug


Attached Files Image(s)
   
Reply
#2
What does the amplifier page look like?

You should have had to chose ethercat as the topology when first creating the motor. This should have meant the amplifier page has the correct one (from the esi file) in the pull down.
Reply
#3
Attached is an image.
I was able to select the amplifier from the pulldown.
There are 3 copies of Omron there....I never really understood that.
Here are pictures of the amplifier screen.


Attached Files Image(s)
       
Reply
#4
Doug,

1) On the Amplifier page, did you make sure to click the "Accept" button on that page? If there is an "Update Database" button, at one point I know there was a bug associated with that and EtherCAT drives, though from your screenshot, you seem to be using a newer version of the IDE after that was fixed.

2) Did you map your input and output PDOs? If there are no PDOs mapped that can be used for those signals, they may show up as Hardware Mismatch.

3) If you click on the "Hardware Mismatch", can you just verify that there is nothing else in the dropdown--that Hardware Mismatch is the only option?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)