Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Counts per Unit in IDE 4
#1
Hello,

First: Sorry, if it sounds a little rough...its not meant to.

I've just tried the new version 4 of the PowerPMAC IDE.
For the last years I've used the version 3, and got used to some bugs here and there.
Now for a new project we wanted to switch to the new IDE, but aside from some disturbing things (No Encoder setup...), I've stumbled over a "big" problem.

We are using the PMAC to control telescopes.
I'm using counts as motor units. But at the end we need usually degrees or some other unit. But not inside the PMAC.
Up until now the "Position Window" in the IDE had the possiblity to modify the displayed "counts per motor unit" - WITH fractional values.
E.g. I have an encoder which has 20480/360 = 56.8888889 counts per degree.

This was purely cosmetic and in the IDE v3 this was possible.
In the new v4 the modification window does not accept fractional values.
So essentially this is not possible as far as I can see.

After looking deeper in the manual and the IDE, one additional thing:
It seems this fuction is not possible, at least not at "the old position".
But:
I DON'T want the Motor[x]PosSF changed! The "User Units Setup" inside the motor setup changes all these values.
I just want the position window display a converted value of the current motor units.
ONLY in the Position Window.

Now my question:
Is this "change of displayed values" still somehow possible in v4?

If yes: How its done?
If no: Why?

Greetings,
Uno
Reply
#2
The User Units section of motor setup is for scaling motor units with Motor[x].PosSf.

To Change the scale on the position window:
1. Select the box or boxes you want to alter and right on one of them. To select multiple boxes, click on the first box and hold shift while clicking the last.
2. Change the number in the "motor units" box. Your motor position will be devided by this number.
3. You may want to change the display units, for example to mm. This will not auto-scale the displayed position.
4. You may also want to change the time units. This will auto-scale the displayed position.

There was also a bug in previous IDE versions that would make the "motor units" box be greyed out. Update to IDE version 4.2.1.19 if you experience this issue.


Attached Files Image(s)
   
Reply
#3
(03-06-2019, 11:26 AM)Eric Hotchkiss Wrote: The User Units section of motor setup is for scaling motor units with Motor[x].PosSf.

To Change the scale on the position window:
1. Select the box or boxes you want to alter and right on one of them. To select multiple boxes, click on the first box and hold shift while clicking the last.
2. Change the number in the "motor units" box. Your motor position will be devided by this number.
3. You may want to change the display units, for example to mm. This will not auto-scale the displayed position.
4. You may also want to change the time units. This will auto-scale the displayed position.

There was also a bug in previous IDE versions that would make the "motor units" box be greyed out. Update to IDE version 4.2.1.19 if you experience this issue.

Hello Eric,

thanks for the quick response.
But you described exactly the problem:
Such an settings window you attached existed also in IDE v3. The difference is,
that in v3 I could input in this factor as a floating point.
In my current case I want to display 56.88889 counts as one unit displayed.

In the IDE v4 I could enter 56.889 or 56,889 and always it is changed to 568889.
So then I get displayed 0.062613 degrees instead of 62,613 degrees.

I hope you see my problem.

Is this only a bug, or is there some intention behind this decision, to allow only integer values in this conversion? After all this unit conversion could be used until now for arbitrary mappings from motor units to user units (as it would be possible with the ScalingFactors of the motor)

Greetings,
Uno
(aka Georg Luthardt)


Attached Files Image(s)
   
Reply
#4
Are you using the latest 4.2.1.19 update? I can enter 56.88889 and it works correctly. It displays as 56.889 after enter is pressed but it appears to use the whole value that was type in.
Reply
#5
(03-07-2019, 05:34 AM)Tony Wrote: Are you using the latest 4.2.1.19 update? I can enter 56.88889 and it works correctly. It displays as 56.889 after enter is pressed but it appears to use the whole value that was type in.

Hello Tony,

tanks for trying.
After your "successful possible" message I fiddled a bit more.

It seems ,that there is a problem with language settings.

The whole Situation for others with this problem:
I'm using an english language windows, but with the region format set to Germany.
Now while programming, I'm using a dot as decimal separator.
I tried this in the position window. It was changed from 56.8889 -> 568889.
I tried the german version with comma. It was changed from 56,8889 -> 568889.

No I've changed the language inside the IDE from "from windows" to explicit English.
After this change, the 56.8889 input is correctly taken and the scaling is right.

It looks to me, that the IDE has some problems with the different number formats. It thinks from windows (german number format) -> ok, dot is bad. But it also does not accept the comma somehow.

After the forced language setting to english, it works...
for now.

So perhaps this is a (temporary) solution. Although it is a problem which should not occur.

Thank your for the help in finding this solution...I hope the main problem which is responsible here, gets fixed in the future.

Greetings,
Uno
Reply
#6
Uno,

I can see what I believe is the same issue with my IDE language set to Spanish. When I set my windows region format to "German (Germany)", set the IDE language to windows default and restart the IDE, the position window seems to work the same as English.

Is this an English installation of windows with that setting changed, or a German installation?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)