Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CK3M Motor Select Problem
Hi All,

In the CK3M controller, as seen in the target of the motor, nothing appears in the "Manufacturer" section, how can I fix this?
How can I add ethercat motor ?

Best regards,

Attached Files Image(s)
Kaan Alkılınç
Omron Electronics TR
The way this works...or has worked in the past, is that the user is expected to create a database of motors (using the "Add to database" button) After motors are added, they will subsequently appear in the dropdown boxes. For EtherCAT, (motors connected solely to the drive) you are likely to have much fewer motor parameters that PPmac has to "know about", as the drive is managing most of that, and you will need to use the EtherCAT drive's configuration software to commission a specific motor.

In system setup, under the motors node, you are expected to associate each motor with a given EtherCAT slave #.

See the relevant section of the PowerPmac IDE User Manual for more details.
EtherCAT drives are supposed to get added to the IDE database when they are added in ESI manager, however a recent Windows 10 update broke it on my PC. I changed the permissions on C:\ProgramData\DeltaTau to allow full access for Users. Once I did this the amplifiers and motors appeared in the list. The fix fix has worked on all but one of the computers I have tried it on.

The patch to IDE V4.2.0.13 also fixed many of the problems I had with configuring EtherCAT drives.
Hi All,

Thank you for reply, I solved problem.
I changed the permissions "C:\ProgramData\DeltaTau"
Kaan Alkılınç
Omron Electronics TR
I am adding XML file of OMRON Coupler ECC203 ver1.6 in IDE 4ver,

IDE 4 is not taking that XML, but when I configured with same xml to ECENGINEER it is working.

Please guide me how to resolve issue
This would be a technical support issue.
Please contact ODT's technical support at:

Forum Jump:

Users browsing this thread: 1 Guest(s)