Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IDE4 - DisplayOrder
#1
Dear all,
On the IDE 4, the scripts files I add or insert are not ordered alphabetically.
It cause variables mapping desorder (between variables in the script (plc/prog) and variables interrogation through gpascii).

Comparing IDE3 and IDE4 project files I found this new tag: <DisplayOrder>2</DisplayOrder>

How can i remove this option ?

Thanks
Reply
#2
If you right-click on the files you can move them up and down in the list. I think that should solve your problem.
Reply
#3
Thank you for your reply Tony.
I think the IDE is not supposed to work that way... the IDE has to order alphabetically automatically.
I tried to uninstall the IDE 4 and to re-install it... same behavior...
Reply
#4
The IDE will download the files in the order they appear in the project manager (with respect to a specific folder). In previous versions, this was always alphabetical, and there was no choice. We had managed this by using prefixes before each file (typically numbering them--"01-<file name>", "02-<file name>", etc.). As Tony noted, as of IDE 4, this is no longer required, as you can now manually re-order the files and therefore the order in which they download.
Reply
#5
Thanks,
so starting at ID4 the script files are not ordered alphabetically.

My issue then might be the mapping done for the C code ("pp_proj.h") which seems to still map using alphabet order.

Please have a look at the attachment. Mapping for C and Script seems different (look at P_01 and P_02:
P_01 is P8193 in Script, but is mapped has P8192 in pp_proj.h


Attached Files Image(s)
   
Reply
#6
It appears as though that is a bug. In the meantime, please re-order your files manually so that they're in alphabetical order, however I will flag this to the software team to be addressed.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)