Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Acc24E3 Amp Enable Relay
#1
Three times in the past few weeks we have had failures of the Amp Enable on the Acc24E3 cards at three different customer sites. These are operating Glentek and Trust drives, both at TTL levels with internal 10k pullups to 5V. These machines have been functioning normally for periods up to two years. Are these physical relays, and if so, what is the MTBF/MTTF?
Reply
#2
(07-18-2018, 07:16 AM)JeffLowe Wrote: Three times in the past few weeks we have had failures of the Amp Enable on the Acc24E3 cards at three different customer sites. These are operating Glentek and Trust drives, both at TTL levels with internal 10k pullups to 5V. These machines have been functioning normally for periods up to two years. Are these physical relays, and if so, what is the MTBF/MTTF?

We have seen similar failures on Acc-24E3 boards: on the amplifier mezzanine card, the 'Clare LBA716 Dual Single-Pole OptoMOS® Relays Normally Open & Normally Closed' relays have failed. Most of the systems have been running for years without problems.
Reply
#3
These are solid state relays. You should be able to download the QC specs from the manufacturer. These have shown to be very reliable. Please contact support@deltatau.com with the card s/n to investigate this issue.
Reply
#4
(07-18-2018, 02:01 PM)steve.milici Wrote: These are solid state relays. You should be able to download the QC specs from the manufacturer. These have shown to be very reliable. Please contact support@deltatau.com with the card s/n to investigate this issue.

On the one card here I have here I found a dry joint on one of the legs of the gull wing package. A parting line was clearly visible under the Mantis. Probing the pin easily lifted it away from the pad. Possible causes clogged stencil, insufficient paste since this is near the edge of the board, or un-level pins on the component.
Reply
#5
(07-18-2018, 07:34 AM)ibisjoe Wrote:
(07-18-2018, 07:16 AM)JeffLowe Wrote: Three times in the past few weeks we have had failures of the Amp Enable on the Acc24E3 cards at three different customer sites. These are operating Glentek and Trust drives, both at TTL levels with internal 10k pullups to 5V. These machines have been functioning normally for periods up to two years. Are these physical relays, and if so, what is the MTBF/MTTF?

We have seen similar failures on Acc-24E3 boards: on the amplifier mezzanine card, the 'Clare LBA716 Dual Single-Pole OptoMOS® Relays Normally Open & Normally Closed' relays have failed. Most of the systems have been running for years without problems.

J: How many boards have you seen fail? We are on 5 and counting. This failure mode has become very visible to a major customer (18 machines, and more pending) so I really need to find some answers. My contacting the chip vendor for reliability data on the board is just not appropriate.
Reply
#6
Please send pictures of any boards that appear to have manufacturing issues to support@deltatau.com.
Reply
#7
(09-10-2018, 09:40 AM)steve.milici Wrote: Please send pictures of any boards that appear to have manufacturing issues to support@deltatau.com.

The one board with a visible crack in the solder joint was repaired and placed into production. I did not get a picture, nor was the serial number recorded. The remaining four boards are at Axis now being evaluated. They are all 1-2 years old and have been functioning normally up to the point of failure.
Reply
#8
Always contact ODT technical support for manufacturing issues at support@deltatau.com.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)