Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble saving my code to flash
I am struggling to save my code to flash memory. Here are the steps I am taking:

From the terminal: "$$$***" to reset to factory defaults
Right-click on PPCNC_ProjectSource in the Solution Explorer and select "Build and Download All Programs"
From the terminal: "save" to save to flash

The results seem to indicate the save worked:

Successful: SaveConfiguration using /var/ftp/usrflash/Project/Configuration/pp_save.cfg

Successful: SaveCustomConfiguration using template /var/ftp/usrflash/Project/Configuration/pp_custom_save.tpl

SaveToFlash: Do NOT Power off until Finished!!!

availabe_space = 290912K 2524K
required_space = 2524K
SaveToFlash: cp

SaveToFlash: sync()

SaveToFlash: mount

SaveToFlash: Finish SAVING to Flash.

Save Complete

However if I reboot the machine my code is not loaded. Also if I factory reset and then normal reset ($$$*** then $$$) my code is not reloaded.

Can anyone point out what I am doing wrong? I thought this was the exact procedure I followed on my other PowerBrick and it seemed to work there.
Do you by chance have a USB drive inserted into the PPMAC? If so, make sure it does not have any of the folders with names listed in this post:

Especially make sure you do not have a folder named "PowerPmacFactoryReset" in the USB drive.
If you do not have a USB drive plugged in, try to issue $$$***, SAVE, and $$$ first, then Build and Download, SAVE, $$$ again.
@AAnikstein Your solution worked. Do you know why I would have to do something like that?
Yes and no.

When you update the firmware via the IDE, it does instruct you to do that afterwards. Basically, after a firmware update, the PMAC may not run its script to auto-detect hardware. Because of this, it may believe you have hardware <A>, when in reality, you are using hardware <B>. When you then do a build and download and save, it actually does complete successfully, however when you power cycle, PMAC will compare what it believes you have with what is actually present, detect that they are different, and for safety reasons, it will factory reset itself. Manually issuing $$$*** forces PMAC to run this script, and then issuing the save command afterwards updates PMAC such that it saves the knowledge of what hardware was detected.

That said, I am not completely aware of the exact details why the user must issue these commands compared to the auto-detect being run or us just automatically issuing these commands after a firmware update.

If you have not updated your firmware recently, please email support at deltatau dot com referencing this thread, because I would be curious if something else might cause this condition--to my knowledge, every time I've seen it was after a recent firmware update.
@AAnikstein This is no longer working for me, anything else I can do to be able to save my firmware to flash?

Forum Jump:

Users browsing this thread: 1 Guest(s)