Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Plot not working on "heavy" machine
#1
Hi all,
I have a machine which is quite "heavy" (16 analog axes plus 16 ethercat).
Due to a spontaneous reboot problem I was forced to disable the critical interrupt, but this led to a much more slugghish communication.
Sys.BgSleepTime has been set to 2000 to mitigate for this.

If I want to use the plot function on this machine I have to increase it even further but somethimes this is not enough, the plot tries to open and then ends up in closing itself.

In the output window I get this error: Plot: startindex cannot be larger than length of string

What could cause this error?
Reply
#2
Please email the details of the hardware used and the project to support@deltatau.com.
Reply
#3
(02-14-2018, 07:31 AM)tecnico Wrote: Hi all,
I have a machine which is quite "heavy" (16 analog axes plus 16 ethercat).
Due to a spontaneous reboot problem I was forced to disable the critical interrupt, but this led to a much more slugghish communication.
Sys.BgSleepTime has been set to 2000 to mitigate for this.

If I want to use the plot function on this machine I have to increase it even further but somethimes this is not enough, the plot tries to open and then ends up in closing itself.

In the output window I get this error: Plot: startindex cannot be larger than length of string

What could cause this error?

Would it be possible to report the evaluation and resolution of this problem here on the Forum for all to see?
This looks like it would be interesting to me.
Thank You
Reply
#4
The problem looks like a combination of critical interrupt disabled and rticplc: when running with critical interrupt disabled my rticplc takes up 40% of the CPU0 despite being 30-40 lines long.
I was suggested by ODT CH support to transform the rticplc in a cfromscript() and have it called from PLC0.
This seems to solve the issue
Reply
#5
Thank You
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)