Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PMACPlotPro2
#1
Hello,

I'm trying to use PMACPlotPro2 to log the response of motors to a motion program. Attached the program, data points and the position and velocity plots.

I tried a simple jog motion of X axis as well. Attached the plots.

The plots I get out of PMACPlotPro2 doesn't make any sense! The connection to the PMAC works well and I have checked this multiple times.

It would be great if I can get any help on how to fix this.

Thank you!


Attached Files
.pdf   UY.pdf (Size: 41.7 KB / Downloads: 10)
.pdf   UYmotion.pdf (Size: 192.17 KB / Downloads: 6)
.zip   PlotTest.zip (Size: 8.78 KB / Downloads: 5)
Reply
#2
It would be helpful if you sent your motion program as a text file, NOT PDF.
Reply
#3
Attached the text file.

(07-26-2017, 04:56 AM)DaveBarnett Wrote: It would be helpful if you sent your motion program as a text file, NOT PDF.


Attached Files
.txt   UY.txt (Size: 6.45 KB / Downloads: 8)
Reply
#4
I took your motion program and ran it on a PowerPmac. It’s not clear to me what exactly you are trying to achieve, but I noticed a few things.
I had to clean up the file on a line or two…(see attached motion program)
The sinusoidal portion of the data is distorted (not a clean sinusoid). You can see this from a plot of commanded velocity (see plot attached). This is usually caused by incorrectly calculating the velocity portion of the PVT segments, which should ideally match their slopes (accel) on segment boundaries.

Is that what you are referring to as “jittery motion“ ? Not sure what your plots are showing…I didn’t see any sinusoidal portions in them. ??


Attached Files Image(s)
   

.txt   PVT_powerPmac.txt (Size: 6.47 KB / Downloads: 4)
Reply
#5
Hi Dave,

Thanks for the help with this.

Noted the changes to motion program, I'll implement those.

I'm not sure why the commanded velocity is distorted. If you see the plots vU and vY in the attached PDF, the velocity looks clean. That's one cycle of the run.

I guess this is what causes the "jittery" motion.

(07-26-2017, 03:01 PM)DaveBarnett Wrote: I took your motion program and ran it on a PowerPmac. It’s not clear to me what exactly you are trying to achieve, but I noticed a few things.
I had to clean up the file on a line or two…(see attached motion program)
The sinusoidal portion of the data is distorted (not a clean sinusoid). You can see this from a plot of commanded velocity (see plot attached). This is usually caused by incorrectly calculating the velocity portion of the PVT segments, which should ideally match their slopes (accel) on segment boundaries.

Is that what you are referring to as “jittery motion“ ? Not sure what your plots are showing…I didn’t see any sinusoidal portions in them. ??


Attached Files
.pdf   UYmotion.pdf (Size: 192.17 KB / Downloads: 7)
Reply
#6
Hi Dave,

I had made an error in the time step calculation. I have corrected it in the attached code. Could you please check the commanded velocity plots for this program?

On the other hand, I'm still not sure how to fix PMACPlotPro2.

(07-26-2017, 03:44 PM)vignesh90 Wrote: Hi Dave,

Thanks for the help with this.

Noted the changes to motion program, I'll implement those.

I'm not sure why the commanded velocity is distorted. If you see the plots vU and vY in the attached PDF, the velocity looks clean. That's one cycle of the run.

I guess this is what causes the "jittery" motion.

(07-26-2017, 03:01 PM)DaveBarnett Wrote: I took your motion program and ran it on a PowerPmac. It’s not clear to me what exactly you are trying to achieve, but I noticed a few things.
I had to clean up the file on a line or two…(see attached motion program)
The sinusoidal portion of the data is distorted (not a clean sinusoid). You can see this from a plot of commanded velocity (see plot attached). This is usually caused by incorrectly calculating the velocity portion of the PVT segments, which should ideally match their slopes (accel) on segment boundaries.

Is that what you are referring to as “jittery motion“ ? Not sure what your plots are showing…I didn’t see any sinusoidal portions in them. ??


Attached Files
.txt   UYmotion_correct.txt (Size: 5.64 KB / Downloads: 3)
Reply
#7
Your most recent plot is an Excel plot of the velocity points in your program...correct ?
This is not the same as the velocity of the 3rd order curve that Pmac calculates from your data.
(and that I plotted)
Reply
#8
Hi Dave,

Yes those were excel plots. Is there any documentation on how PMAC calculates the velocity so I can understand this better?

Thanks!

(07-26-2017, 06:12 PM)DaveBarnett Wrote: Your most recent plot is an Excel plot of the velocity points in your program...correct ?
This is not the same as the velocity of the 3rd order curve that Pmac calculates from your data.
(and that I plotted)
Reply
#9
You can have a look at page 56 of this manual for a detailed description:

http://www.deltatau.com/manuals/pdfs/PMA...3265509314
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)