Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
apt-get fails
#1
I am trying to setup lighttpd on a power pmac. I have the power pmac connected to the web through a DNS server and I can ping http://www.google.com successfully from the pp. When I try to do an
apt-get update
or
apt-get build-dep lighttpd
I get a long list of error messages about not being able to resolve the mirror.anl.gov
sample error message.
Err http://mirror.anl.gov lenny/main libglib2.0-0 2.16.6-2
Could not resolve 'mirror.anl.gov'

I have tried pinging this server from my mac as well as the pp and I am unable to reach it from either machine.

I have the source code for lighttpd but when i try to run the configuration program it give me the following error
configure: error: pcre-config not found, install the pcre-devel package or build with --without-pcre

I am in the process of setting up lighttpd to host a cgi webpage programmed in C++ so I could probably compile without pcre as it is related to pearl but i would like to build it with pearl support.
Reply
#2
I think this forum link below is the same problem I am seeing. I don't know how I would go about changing the update source as it suggest in the link below or if it is a good idea.
http://forums.debian.net/viewtopic.php?f=30&t=78447

Here is the output from my apt-get update it looks to be the same issue discussed in the link above.

192.168.0.21:/opt/ppmac# apt-get update
Ign http://security.debian.org lenny/updates Release.gpg
Ign http://security.debian.org lenny/updates/main Translation-en_US
Ign http://security.debian.org lenny/updates Release
Ign http://security.debian.org lenny/updates/main Packages/DiffIndex
Ign http://security.debian.org lenny/updates/main Sources/DiffIndex
Err http://mirror.anl.gov lenny Release.gpg
Could not resolve 'mirror.anl.gov'
Err http://mirror.anl.gov lenny/main Translation-en_US
Could not resolve 'mirror.anl.gov'
Ign http://security.debian.org lenny/updates/main Packages
Ign http://security.debian.org lenny/updates/main Sources
Ign http://security.debian.org lenny/updates/main Packages
Ign http://security.debian.org lenny/updates/main Sources
Err http://security.debian.org lenny/updates/main Packages
404 Not Found [IP: 128.31.0.63 80]
Err http://security.debian.org lenny/updates/main Sources
404 Not Found [IP: 128.31.0.63 80]
Ign http://volatile.debian.org lenny/volatile Release.gpg
Ign http://volatile.debian.org lenny/volatile/main Translation-en_US
Ign http://volatile.debian.org lenny/volatile Release
Ign http://volatile.debian.org lenny/volatile/main Packages/DiffIndex
Ign http://volatile.debian.org lenny/volatile/main Sources/DiffIndex
Ign http://volatile.debian.org lenny/volatile/main Packages
Ign http://volatile.debian.org lenny/volatile/main Sources
Ign http://volatile.debian.org lenny/volatile/main Packages
Ign http://volatile.debian.org lenny/volatile/main Sources
Err http://volatile.debian.org lenny/volatile/main Packages
301 Moved Permanently [IP: 130.89.148.14 80]
Err http://volatile.debian.org lenny/volatile/main Sources
301 Moved Permanently [IP: 130.89.148.14 80]
Reading package lists... Done
W: Failed to fetch http://mirror.anl.gov/debian/dists/lenny/Release.gpg Could not resolve 'mirror.anl.gov'

W: Failed to fetch http://mirror.anl.gov/debian/dists/lenny...-en_US.bz2 Could not resolve 'mirror.anl.gov'

W: Failed to fetch http://security.debian.org/dists/lenny/u...c/Packages 404 Not Found [IP: 128.31.0.63 80]

W: Failed to fetch http://security.debian.org/dists/lenny/u...ce/Sources 404 Not Found [IP: 128.31.0.63 80]

W: Failed to fetch http://volatile.debian.org/debian-volati...c/Packages 301 Moved Permanently [IP: 130.89.148.14 80]

W: Failed to fetch http://volatile.debian.org/debian-volati...ce/Sources 301 Moved Permanently [IP: 130.89.148.14 80]

W: Some index files failed to download, they have been ignored, or old ones used instead.
W: You may want to run apt-get update to correct these problems
root@192.168.0.200
Reply
#3
This thread may help you out:

http://forums.deltatau.com/showthread.php?tid=2056
Reply
#4
Thanks shansen that looks like the information I need.
Reply
#5
I am a little feather along now. When I made the change listed in the other thread I was able to get it to start an update but I ended up with an error need to add sources to source.list. I found a debian source list generator below but i don't know which version of debian is the correct one to build a source list for. My concern is that i don't want to have the update try to update the kernel by mistake.
https://debgen.simplylinux.ch/
Reply
#6
1.) Make your disk writable

mount -o remount,rw /

2.) Next you must update the repository list file. Debian lenny is used on a 460 CPU so you must change the repositories to archive.debian.org.

deb http://archive.debian.org/debian/ lenny main non-free contrib
deb-src http://archive.debian.org/debian/ lenny main non-free contrib
deb http://archive.debian.org/debian-security/ lenny/updates main non-free contrib
deb-src http://archive.debian.org/debian-security/ lenny/updates main non-free contrib

The sources.list file placed in /etc/apt should look like what is above

3.) next issue the apt-get update command to reload the repositories. You can disregard the KEYEXPIRED warning message that comes back


4.) next issue the apt-get install lighttpd command to install lighttpd

lighttpd is now installed.

5.) Make sure the modifications from the apt-get install command make it to the readonly etc folder. Do this by issuing the following command

cp -a /.readonly/etc-tmpfs-mirror/* /.readonly/etc/

6.) Put the disk back to readonly mode
mount -o remount,ro /
Reply
#7
Thanks Henry that worked I can now use the apt get again.
Reply
#8
Henry I have to change the port for lighttpd to port 81. There is a program mono listening on port 80. Any idea what mono is and why it would be listening on port 80? I ask because 80 is the default http port so it would be nice to put the web server on 80 but I don't know what mono is or why it would be on port 80.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)