Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LabVIEW interfacing with PMAC, Jog issue
#1
Dear all, We are using PMAC PCI Lite - 4 axis motion controller card. Out of 4 we are using 3 axes with incremental encoder and analog output from PMAC to drive (PWM not used so there is no commutation). We are using LabVIEW 8.2 as frontend HMI/MIMIC. To communicate LabVIEW with PMAC we are using LabVIEW library file with vi(LabVIEW code) shared by Delta Tau.
In this system we are facing following issues. Please let me know how to solve these issues.

1. During uploading of motion code from LabVIEW sometime one or more line of code missing. How can we read the uploaded motion code back from LabVIEW?
2. We are giving J+ or J- command from PMAC PLC code. Sometime PMAC missing to execute these motion commands. For debugging this we added temp. variables before and after motion command lines. Those temp. variables are setting properly. From this we understood PLC executing all those line of codes but PMAC missing to receive the command and/or not performing the motion accordingly.
Why it is missing to execute those motion command lines sometime. This is not happening all the time. Most of the time it is executing all the motion code properly and motion happening as expected.
3. We wrote few line of PMAC PLC code to perform J+ and J- command until axis hits hard limit switch and return. During the operation J+ movement happened with set jog speed but J- movement happening more than set jog speed approx. double or triple the speed. Why it is moving more than set jog speed for the jog command?
4. When axis is positioned at some level say 2000 counts, actual position(Mx62) and commanded position(Mx61) will be same with negligible following error. If we are setting commanded(Mx61) position to 8000 counts what will be the system response.
If the fatal following error limit is set at 3000 count will it generate fatal following error by setting fatal following error flag or with the sudden movement PMAC will try to correct the position error?
Reply
#2
Please contact support@deltatau.com and we can help you troubleshoot your application issues.
Reply
#3
(04-17-2015, 04:35 PM)steve.milici Wrote: Please contact support@deltatau.com and we can help you troubleshoot your application issues.

Thank you, sent mail to support@deltatau.com and waiting for the response
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)