Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with Motor[x].DesPos not being filtered
#1
Hi,

I'm sending position commands to the PMAC in the form of step input and 99% of the time it uses the Motor[x].JogTa paramemeter to limit the acceleration (Motor[x].JogTs=0.0). However, there is a 1% time when the PMAC seems to disregard this setting and allows spikes in the acceleration. For me this is causing overvoltage problems on my power supply side and following errors.

Does anyone know what could cause the PMAC to disregard the Ta setting and how can I prevent this from happening?

I've attached two files showing a good case and the bad case. In both files, look at the second plot. In the good run you will see the commanded position (red trace) accelerate nicely to a step command (bluish trace). However, in the bad run, you will see the commanded position jump all over the place in response to a step command.

The firmware version is 1.5.8.0.
Settings:
Motor[0].JogTa=-3 (HA axis)
Motor[0].JogTs=0
Motor[2].JogTa=-2.5749967 (DEC axis)
Motor[2].JogTs=0

Thanks,
windell


Attached Files
.pdf   goodmove.pdf (Size: 167.69 KB / Downloads: 19)
.pdf   badmove.pdf (Size: 151.3 KB / Downloads: 16)
Reply
#2
Hi,

How exactly are you issuing the step move? Can you post the code you use for that?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)