Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WIN 7 Upgrade Problems
#1
Hi
I'm new to this forum and am a rookie to PMAC programming and set-up. I have two machines, very simple each with a single axis, connected to a control box (built and set up by a third party) which contains a PMAC2 controller. The first unit has been working just fine for about 2 years, then the PC that runs the operator interface (Labview-based) was upgraded to WIN 7. I had to reinstall the PMAC software. Had problems, but eventually figured out I had to upgrade the USB driver and got it working again. Everything OK now, EXCEPT, that I need to change a few I-variables (130 thru 134 and 902). Using Pwin32PRO ver 4.4.0.0 I change the variables and everything is great. But when I shut down the input power (440 volt) for maybe an hour or so, some of the changed variables revert to their original setting.

I'm also building a second machine just like the first, and its PC also has WIN7. New install for all the software etc. and it has exactly the same problem. I assume the problem must have something to do with the WIN7 change, but can't figure out how to solve it. Any help would be much appreciated.

thanks
Reply
#2
Kaydon,

After you changed the I-vars, did you do a 'SAVE'? I have not had any experience with a PMAC2, but some of the ISA PMACs have a battery, others have flash. If yours has a battery, that would certainly be something to check out.

Cheers,
Steve
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)