Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 7 with Delta Tau Software - Does it work ?
#1
04/06/10
I have not seen any discussion on this subject yet nor any official releases from Factory on Win7 support. The following is my experience getting it to work.

My System:
-Macbook Pro, BootCamp 3.1, Win7 Ultimate 64bit

-First Download and install latest Pewin Pro2 Suite from DT website
-I downloaded v4.2.11.0, installed with no problems
-Next download the 64bit drivers from DTau website "DT64bitDrivers.zip"
-I downloaded these to a directory, unzipped and ran the setup.exe
-Next started PeWin with no problems
-Connected a Geo Brick with USB to PC, Win7 tried but failed driver install
-It showed up in Device Mgr as a ACC54E USB device and no driver found
-I uninstalled the DT 64bit driver, just run the setup.exe again and select
the uninstall option
-Reinstall DT 64bit driver, it shows a path to install to but I never found any drivers installed to that path ? I tried to tell it to go to a different directory but this did not happen, I searched PC for the driver it said installed but never found it ?
-I power cycled the Brick and unplugged the Usb several times, uninstalling the failing driver in Device Mgr, this did not help
-After 3 times uninstall/reinstall DT64bit driver, the Driver installed fine
-Now in Device Mgr I have a Motion Controllers Group with "Delta Tau UMAC USB 2.0 Device" in it
-Now it is all working fine.

-I tested with a SIIG USB to Serial Adapter
- Part #: JU-CB1S12-S3 Hardware V3
- Win7 found driver for this no problem
- Started PeWin, Installed New PMAC Device SER3, Com3
- talked to Brick with no problems

-I tested with Ethernet connection to Brick
-Started PeWin, Installed New PMAC Device Eth with IP
-this worked fine, could talk to Brick with no problems

-Now See 2 PMAC Driver files in \Windows\System32\Drivers
PmacPCI.sys 3/30/2009 2:37 PM 44KB
pmacusb.sys 3/30/2009 2:37 PM 43KB

-So once I got the USB driver to be properly recognized and show up under a "Motion Controllers" Group in the Device Mgr all is working fine. I'm not sure what it took to make this happen, perhaps with more installs we can figure out the proper procedure to make it work first time every time.

-Please add you comments or what you have found to work. I'm sure that soon the Factory will also create a official Win7 Support document.
#2
Update 5/12/2010 to install Pewin Pro2.

I had a new install of Win7 to install Pewin on and took a more
logical approach this time and it installed perfect first try.

1. Started with new fresh install on Win7 Ultimate 64bit
2. Downloaded from DT website PewinPro2 Suite v4.2.11.0 (3/11/10)
3. Installed with defaults
4. With USB plugged into a Geo Brick connected USB to PC
-it found and installed driver for ACC-54E, which does NOT work
5. Unplugged USB, make sure ACC-54E is gone from device mgr
5. Downloaded 64bit drivers from DT site, Installed with all defaults
6. Win7 Restart, Geo Brick Power cycle
7. Plugged in USB to PC - it sees and installs proper driver OK
-in Computer - Device Manager - Motion Controllers -
Delta Tau UMAC USB 2.0 Device
8. Started Pewin - Setup - General - Select - Insert - USB
9. Now all works fine...

So I think proper procedure is to First install Pewin suite, Next install 64bit driver, Restart windows - plug in USB from PMAC device - should create in Device Mgr - Motion Controllers - Delta Tau UMAC USB 2.0 Device

Let me know if you have any questions: mesposito@deltatau.com
#3
Here added details on problem when trying to add a new PMAC device in Pewin Pro2.

-issue is when adding the Eth PMAC it won't show up in list after adding it...

-Problem is with Win 7 user permissions.

-To fix Win7:
1. Control Panel - User Accounts - Select "Change User Account Control Settings"
2. In here Slide the "UAC" slide bar to bottom = "Never Notify"
3. OK - Exit Control panel
4. Now you MUST Reboot the PC.... change will NOT take effect until you reboot.

-To add the Ethernet device to PMAC list:
1. Start PewinPro2 - go to Setup - General Setup and Options
2. Select the [Select] button
3. Select a blank slot in PMAC list of devices - e.g. PMAC 00
4. Insert - New - Eth - OK
5. Enter the IP Address for your PMAC
6. Use the "Network Test" button to be sure you can "PING" it ok
7. OK
8. Now it should appear in list of "PMAC devices not registered:"
9. Select the new PMAC from this list - OK
10. Now the new Eth PMAC should be in the list of PMAC Devices
11. you can select this PMAC - OK - and start talking to it


Forum Jump:


Users browsing this thread: 1 Guest(s)