Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Download C source files problem

I have a systematic issue since the previous IDE release. I was hoping that the IDE 1.7 version would fix it, but it did not... Here is my (very annoying) problem: each time I download all programs to a PowerPMAC, each C source files included in the current project are downloaded to the PowerPMAC too! As I have a lot of them, it takes a huge amount of time to download the project...

I saw in the PowerPMAC project general properties the "Download C Source Files" option, but no manner what the option is (Yes or No) it does download all the C source files!

Is it a known issue? Do you have any idea of what I could do in order to prevent the C file to be downloaded?

Thanks in advance for your replies!

I think this is not bug.
The source files in your PPMAC directory may be exist before you download the Project.
Because at boot time PPMAC copies saved project to /var/ftp/usrflash.
So if previously saved project contains C source file, then it will be copied to /var/ftp/usrflash.

Maybe "Build & Download project" does not delete files already exist.

Connect to your PPMAC with Putty.
And change directory to /var/ftp/usrflash/Project/C\ Language with "cd" command.
Then remove all files and directories inside this folder.
After delete all files then "build & download" project again.

cd /var/ftp/usrflash/Project/C\ Language/
rm -r *

I think that you have many C source files and it takes long time to compile, not downloading project.

I hope someone who is in charge of SW development can add exact replies.
If you do not want C files to compile and download you must do two things.

1. Right click on project and select the "clean" option. This removes all compiled code from the project directories.
2. Right click on the individual C programs and change their "Build Action" properties from "compile" to "content" or "none"

If you do this correctly you will see a red circle with diagonal red line show in front of the C program. Now even a "Build" will not touch this code

If what you want is to compile once and then have the code download but not compile again you must only use the Download All Programs selection instead of Build and Download.
Thank you very much for your replies!

sjlee5: as you advised, I removed all the C files from the usrflash (effectively full of my entire project). However, even with choosing "No" to the "Download C Source Files" option, all the sources are downloaded. This take several minutes, as I see a long list of .c being downloaded.

bradp: my project is already built like this. Almost all my .c files are in "Content" mode. The build option works like a charm, but I cannot prevent the "Download all Programs" from downloading all the sources...

I impart that a colleague of mine working on the same project does not have this issue; but he is still working on the IDE 1.5 release version... The issue appeared when I installed version 1.6...
This means the compiled code is still in the directories on the PC. The Clean is suppose to take care of this. Did you right click on the project and select Clean?

If there is a bug what I imagine it has to be when the file properties say the build action is content then the clean does not work. I do not know if this is true as I do not know if you have tried the clean option.

Also, are you doing anything like encrypting the project or telling it to store the source code on the PPmac?

And the basic question, how do you know the c-code is being downloaded?
Hi bradp, thank you again for your reply.

(07-11-2014, 02:24 AM)bradp Wrote: This means the compiled code is still in the directories on the PC. The Clean is suppose to take care of this. Did you right click on the project and select Clean?

If there is a bug what I imagine it has to be when the file properties say the build action is content then the clean does not work. I do not know if this is true as I do not know if you have tried the clean option.

Yes I always click on "Clean" before "Build and Download All Programs".

(07-11-2014, 02:24 AM)bradp Wrote: Also, are you doing anything like encrypting the project or telling it to store the source code on the PPmac?

No. I never tried anything like that.

(07-11-2014, 02:24 AM)bradp Wrote: And the basic question, how do you know the c-code is being downloaded?

Because I have a long list of "Downloading xxxxxx.c" right after the "Build Succeeded". I attached a screenshot to illustrate.

Attached Files Image(s)
The C source code is only sent to the PPmac if in the project properties you have the option selected to download the C source code. Otherwise only th compiled code is sent. Since you have both being loaded this box must be checked (or the IDE thinks it is). So I have two things for you to do.

1. Right click on the project and go to properties. See if the selection for downloading c source code is set to yes.
2. If point 1 is not the cause then open a new project and build and download. By default the capp1 is compiled and will be loaded. Look in the download log and see if the source code was sent. It will not be. There might be some issue of loading a project built in some older IDE into the the version. The best way around this is to add a project to the solution. Then one by one in the new project use the add existing item selection to copy the files from the old project to the new. Since each project is standalone this should remove any strange screwed up settings.
As I said before, I already turned the download option to "No". So I opened a new project as you advised. By default, the option is still set to "No" as illustrated in the attached screenshot.

However, even with a blank project generated by the last IDE version, the C code is downloaded! I attached another screenshot of the log.

Attached Files Image(s)
What is you PPmac firmware version. Use vers and date in the IDE terminal. I have to find a way to make this happen on my system.
Date 06/30/2014

Thank you very much for your concern!
That is the IDE version and date. I meant the PPmac firmware version and date. To get this you send the command
in the IDE terminal window.
Sorry for the misunderstanding!

Oct 30 2012
Even with the same firmware I do not have the same issue. In fact my download is completely different. When I download I get a black DOS window opening and you seem not to. I see this because my system will not list downloaded C code in the same manner as yours. Mine lists it under the spawn rsynch section where the directories and files are synchronized. Yours is listed under the download section which is from the older method.

Please wait while downloading to Power Pmac.
spawn rsync -e ssh -o StrictHostKeyChecking=no -azrtvl --delete --partial --progress --exclude-from=/usr/bin/Exclude.txt /cygdrive/C/Program Files (x86)/Delta Tau Data Systems Inc/2.0/Projects/PowerPmac13/PowerPmac13/ root@
root@'s password:
sending incremental file list
700 11% 0.00kB/s 0:00:00
5969 100% 5.02MB/s 0:00:00 (xfer#1, to-check=38/40)
C Language/
C Language/Background Programs/
C Language/Background Programs/capp1/
C Language/Background Programs/capp1/capp1.c
1981 100% 128.97kB/s 0:00:00
1981 100% 128.97kB/s 0:00:00 (xfer#2, to-check=21/40)
C Language/CPLCs/
C Language/CPLCs/bgcplc00/
C Language/CPLCs/bgcplc00/bgcplc.c
128 100% 7.35kB/s 0:00:00
128 100% 7.35kB/s 0:00:00 (xfer#3, to-check=17/40)
C Language/CPLCs/rticplc/
C Language/CPLCs/rticplc/rticplc.c
139 100% 7.54kB/s 0:00:00
139 100% 7.54kB/s 0:00:00 (xfer#4, to-check=16/40)
C Language/Include/
C Language/Include/pp_proj.h
700 11% 35.98kB/s 0:00:00
5851 100% 300.73kB/s 0:00:00 (xfer#5, to-check=15/40)
C Language/Realtime Routines/
C Language/Realtime Routines/usrcode.c
1044 100% 50.98kB/s 0:00:00
1044 100% 50.98kB/s 0:00:00 (xfer#6, to-check=14/40)
PMAC Script Language/
PMAC Script Language/Global Includes/
PMAC Script Language/Libraries/
PMAC Script Language/Motion Programs/
PMAC Script Language/PLC Programs/

sent 3651 bytes received 357 bytes 1145.14 bytes/sec

----------------------------- YOURS IS LISTED HERE ----------------------
total size is 182919 speedup is 45.64
Downloading pp_startup.txt to Power Pmac.
Downloading pp_disable.txt to Power Pmac.
Downloading pp_proj.ini to Power Pmac.

Please wait, while loading the project.
Start of Project Loading using INI File: "/var/ftp/usrflash/Project/Configuration/pp_proj.ini"Status: Starting Pass #1, getting project properties
Status: Pass #1, Pre-processing file: /var/ftp/usrflash/Project/PMAC Script Language/Global Includes/global definitions.pmh
Status: Pass #1, Pre-processing file: /var/ftp/usrflash/Project/PMAC Script Language/Libraries/subprog1.pmc
Status: Pass #1, Pre-processing file: /var/ftp/usrflash/Project/PMAC Script Language/Motion Programs/prog1.pmc
Status: Pass #1, Pre-processing file: /var/ftp/usrflash/Project/PMAC Script Language/PLC Programs/plc1.plc
Status: Pass #2, Pre-processing input file = /var/ftp/usrflash/Temp/pp_proj.p1, output file = /var/ftp/usrflash/Temp/pp_proj.p2
Status: Pass #3 , Run CPP input file = /var/ftp/usrflash/Temp/pp_proj.p2, output file = /var/ftp/usrflash/Temp/pp_proj.pma
Status: Downloading to Power Pmac file = /var/ftp/usrflash/Temp/pp_proj.pmaStatus: Successful load of preprocessed File: "/var/ftp/usrflash/Temp/pp_proj.pma"
Success: projpp

uploading pp_error.log file from the Power Pmac.
uploading pp_proj.log file from the Power Pmac.
uploading pp_error_hist.log file from the Power Pmac.
uploading pp_debug.txt file from the Power Pmac.
uploading pp_proj.h file from the Power Pmac.
Uploading and syncing PMAC variables.
Download Successful.
Total Project Download time = 7.207 sec
Total Project Build and Download time = 7.207 sec

So I am not sure what is wrong with your system. My fear is that maybe you did not uninstall the IDE before installing a new version one time and this has caused some problem. But before I tell you to try this I want a developer from CA to look.

On another subject. It is not recommended to use the new IDE with the old firmware as there could be windows and features not working properly. This is not one of them since the same old firmware on my system does not show this problem. Just a general tip.
Ok, thank you very much for your time. As far as I remember I always used the uninstaller... But following your advice, I'm going to downgrade to version 1.5.

Thank you again!
Hmmm. I would rather that you upgrade the PPmac firmware than downgrade the IDE version. Since you will just find some other IDE bug and I will answer you need a new IDE to fix it. Let's see what is told by DTCA programmers before you do something. We should have an answer tomorrow.
OK, I got it. The explanation is complicated. The simple explanation is that firmware and the newer IDEs are not compatible. To get rid of this issue you must upgrade to newer firmware or use the IDE matched to that firmware release unless DTCA fixes this issue in an even newer IDE. I would not wait for that, it probably will not happen.

The long explanation;
Sometime the start of this year the IDE started using a package called rsync to synchronize the directories between the PC project and the PPmac project. Old firmware did not have rsync so the IDE should be backwards compatible. Seems like with old firmware the C source code gets loaded even though it should not.

But if you even install a newer firmware on the PPmac then the rsync package gets installed. Going backwards to old firmware does not remove rsync and that is why my test yesterday with still worked. That CPU had new firmware and I downgraded.

Today I reflashed a CPU so it never had the rsync package installed. Now my system behaves as yours.

Anyway, mystery solved, and you know your options. Sorry for the trouble.
I am testing it and I will let you know the answer soon but It looks like a bug in the IDE. Since you have older version of the firmware, the newer IDE does not check to see if the C source download flag is set and simply downloads everything. If you upgrade the firmware, and choose not to download the C source, you will see that it does work. If you wish to keep your current version of the firmware it won;t be a problem because I am going to fix the bug anyways.
Great, it worked! Thank you very much! I upgraded the firmware to the last available version ( and the "build and download" process deleted all the .c files. Now it does not download them anymore. And my computer's firewall well detected rsync!

Sorry for the bothering and thank you again for your time! In the future I'll keep updated the firmware together with the IDE.

Forum Jump:

Users browsing this thread: 1 Guest(s)