Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with CK3E and Kollmorgen AKD
#17
Still getting the duplicates issue but with different servo

This time Mitsubishi MRJ4-TM-ECT.

The inputs are duplicated (only one time but still annoying)

#define Slave_4_6061_0_Modesofoperationd ECAT[0].IO[4122].Data
#define Slave_4_6041_0_Statusword ECAT[0].IO[4123].Data
#define Slave_4_2D11_0_StatusDO1 ECAT[0].IO[4124].Data
#define Slave_4_2D12_0_StatusDO2 ECAT[0].IO[4125].Data
#define Slave_4_2D13_0_StatusDO3 ECAT[0].IO[4126].Data
#define Slave_4_6064_0_Positionactualval ECAT[0].IO[4127].Data
#define Slave_4_606C_0_Velocityactualval ECAT[0].IO[4128].Data
#define Slave_4_60F4_0_Followingerroract ECAT[0].IO[4129].Data
#define Slave_4_6077_0_Torqueactualvalue ECAT[0].IO[4130].Data
#define Slave_4_60B9_0_Touchprobestatus ECAT[0].IO[4131].Data
#define Slave_4_60BA_0_Touchprobepos1pos ECAT[0].IO[4132].Data
#define Slave_4_60BB_0_Touchprobepos1neg ECAT[0].IO[4133].Data
#define Slave_4_60BC_0_Touchprobepos2pos ECAT[0].IO[4134].Data
#define Slave_4_60BD_0_Touchprobepos2neg ECAT[0].IO[4135].Data

#define Slave_4_6061_0_Modesofoperationd ECAT[0].IO[4136].Data
#define Slave_4_6041_0_Statusword ECAT[0].IO[4137].Data
#define Slave_4_2D11_0_StatusDO1 ECAT[0].IO[4138].Data
#define Slave_4_2D12_0_StatusDO2 ECAT[0].IO[4139].Data
#define Slave_4_2D13_0_StatusDO3 ECAT[0].IO[4140].Data
#define Slave_4_6064_0_Positionactualval ECAT[0].IO[4141].Data
#define Slave_4_606C_0_Velocityactualval ECAT[0].IO[4142].Data
#define Slave_4_60F4_0_Followingerroract ECAT[0].IO[4143].Data
#define Slave_4_6077_0_Torqueactualvalue ECAT[0].IO[4144].Data
#define Slave_4_60B9_0_Touchprobestatus ECAT[0].IO[4145].Data
#define Slave_4_60BA_0_Touchprobepos1pos ECAT[0].IO[4146].Data
#define Slave_4_60BB_0_Touchprobepos1neg ECAT[0].IO[4147].Data
#define Slave_4_60BC_0_Touchprobepos2pos ECAT[0].IO[4148].Data
#define Slave_4_60BD_0_Touchprobepos2neg ECAT[0].IO[4149].Data

I thought it was a Kollmorgen-related problem but now it looks more likely to be a problem of the Acontis master.
Any chance that using a newer firmware (actual is 2.4.1.2) can help in this regard?

I can add more details: the proposed input mappings are 0x1A00 and 0x1A01
The duplicated names are the PDOs that exist in both the mappings
Editing the XML changing just the name prevents the PDOs from being duplicated.

of course it's not normal to have to edit a OEM XML descriptor, because each time the manufacturer releases a new version you have to redo the work.

I can provide original and edited xml on request. Can't seem to be able to attach xml or zipped xml


Attached Files Image(s)
   
Reply


Messages In This Thread
RE: Problems with CK3E and Kollmorgen AKD - tecnico - 06-06-2019, 05:10 AM

Forum Jump:


Users browsing this thread: 1 Guest(s)