Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SDO
#4
This thread is very helpful but I encounter a problem trying these examples
I tried the following lines:
L0=ecattypedsdo(0,3,1,$1016,0,0,4) L0
L0=ecattypedsdo(0,3,1,$6060,0,0,1) L0
L0=ecattypedsdo(0,4,1,$6007,0,0,2) L0
but all i get is "-nan"

Slave num 3 and 4 are MackTron motors by Axor and working well with CSP mode.

It's PowerPmac IPC MotionCore with Sys.EcatType=1 (Actonics)

I tried when ECAT[0].enable=1 (enable) and also when ECAT[0].enable=0 (disable)

any tips how to get it working?

(07-20-2017, 08:25 AM)masher Wrote:
koustubh_h datneline='1500448157' Wrote: How can i access SDO (service data objects) in PowerPMAC?
... i need to set some SDO's like 0x6002...

Please see the attached .pdf for a couple of SDO read/write examples. You may also want to try typing any PMAC command into the terminal window and press the, "F1" key for help. Then set the filter, pull down menu to PMAC. This was not implemented in older versions of the IDE but now is available and very useful.

NOTE: Etherlab Master Stack can use either ecatsdo(), or ecattypedsdo() commands. Acontis Stack only uses the ecattypedsdo() command.

The 465 with EtherCAT comes equipped with the Etherlab Master Stack. You can test this by issuing the sys.ecattype command.
sys.ecattype = 0 (Etherlab)
sys.ecattype = 1 (Acontis)
Reply


Messages In This Thread
SDO - koustubh_h - 07-19-2017, 12:09 AM
RE: SDO - illop - 07-19-2017, 12:34 AM
RE: SDO - masher - 07-20-2017, 08:25 AM
RE: SDO - orhirshfeld - 03-03-2019, 02:17 AM

Forum Jump:


Users browsing this thread: 2 Guest(s)